
  



<!DOCTYPE html>
        <html lang="en">
        <head>
<base href="http://www.technicianonline.com/content/tncms/live/" />
<meta name="keywords" content="ncsu football, wolfpack football, gopack football, nc state football, russell wilson, the nfl, carter-finley stadium, super bowl, commencement speaker, national football league, quarterback, jeff williams, nfl, randy woodson, ashley christensen, walter payton man, the pro bowl, chancellor" />
<meta name="news_keywords" content="ncsu football, wolfpack football, gopack football, nc state football, russell wilson, the nfl, carter-finley stadium, super bowl, commencement speaker, national football league, quarterback, jeff williams, nfl, randy woodson, ashley christensen, walter payton man, the pro bowl, chancellor" />
<meta name="description" content="NC State announced on April 19 that former Pack football QB Russell Wilson will speak at this year's commencement ceremonies." />
<meta name="author" content="Staff Report" />
<meta name="viewport" content="width=device-width, initial-scale=1.0" />
<meta name="apple-mobile-web-app-capable" content="yes" />
<meta name="apple-mobile-web-app-status-bar-style" content="black-translucent" />
<meta property="og:type" content="article" />
<meta property="og:url" content="http://www.technicianonline.com/sports/article_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html" />
<meta property="og:image" content="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/4/e6/4e67e436-ec62-11e8-a5d6-5fb5b38de91b/5bf361181dc71.image.jpg?resize=949%2C630" />
<meta property="og:image:width" content="949" />
<meta property="og:image:height" content="630" />
<meta property="og:title" content="NC State announces Russell Wilson as 2021 commencement speaker" />
<meta property="og:description" content="NC State announced on April 19 that former Pack football QB Russell Wilson will speak at this year's commencement ceremonies." />
<meta property="og:site_name" content="Technician" />
<meta property="og:section" content="Sports" />
<meta property="fb:app_id" content="1071739619851407" />
<meta name="twitter:card" content="summary_large_image" />
<meta name="twitter:site" content="@ncsutechnician" />
<meta name="twitter:image:alt" content="FBvsBC Russell Wilson Runs" />
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/styles/bootstrap.min.44f4ed00052aeaf66307fd409db0d101.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/styles/layout.88630b645c9697f0c3abcfa274bd39d5.css"/>
<link rel="stylesheet preload" as="style" href="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/shared-content/art/tncms/templates/libraries/flex/components/themes/resources/styles/theme-basic.0740431ec2aa31f2e7d813ea5c660a8d.css"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Fjalla+One"/>
<link rel="stylesheet" href="https://fonts.googleapis.com/css?family=Droid+Serif"/>
<style>/*<![CDATA[*/ #block-490078 .search-spinner { position: absolute; } #block-490078 .input-group-btn:last-child > .btn, .input-group-btn:last-child > .btn-group { margin-left: 0; } #site-search-490078 { margin-bottom: 0; } #site-search-490078 .site-search-form { padding: 0; } #site-search-490078 #site-search-490078-btn { outline: none; } #site-search-490078 #site-search-490078-term { border: 0; box-shadow: none; } #site-search-490078 .site-search-form { box-shadow: none; } #tncms-block-490073 .tnt-prop-img { max-width: 1029px; } #block-490076 .search-spinner { position: absolute; } #block-490076 .input-group-btn:last-child > .btn, .input-group-btn:last-child > .btn-group { margin-left: 0; } #site-search-490076-dropdown .dropdown-menu { padding: 15px; width: 400px; font-weight: normal; } @media screen and (max-width: 991px) { #site-search-490076-dropdown .dropdown-toggle { display: none; } #main-navigation .navbar-left { clear: both; } #site-search-490076-dropdown .pull-right { float: none!important; } #site-search-490076-dropdown .dropdown-menu { display: block; position: static; float: none; width: auto; margin-top: 0; background-color: transparent; border: 0; box-shadow: none; border-radius: 0; border-bottom: 1px solid rgba(0,0,0,0.1); } } .follow-links-490079 li { margin-right: 1px; padding: 0; } .follow-links-490079 li a, .follow-links-490079 li a:focus, .follow-links-490079 li a:active { ; color: #FFF!important; font-size: 18px; margin-right: 10px; opacity: .8; padding:0; box-shadow: none; } .follow-links-490079 li a:hover { text-decoration: none; opacity: 1; } .follow-links-490079 li a.fb:hover { color: #3A59A5; } .follow-links-490079 li a.tw:hover { color: #46C8F9; } .follow-links-490079 li a.yt:hover { color: #CE2B29; } .follow-links-490079 li a.is:hover { color: #D4C4A2; } .block.light .card a.btn-default, .block.light .card a.btn-default:hover { color: #333; } #block-901401 .card .card-image-full { width: 100%; } #block-901401 #card-showcase-9d9ce560-126c-11eb-b3bb-978763f644d7 .showcase-box { width: 24% } #block-983835 .tnt-slider-controls { text-align: right; padding-bottom: 30px; margin: 10px 0px; position: relative; top: 0%; transform: translateY(0%); -webkit-transform: translateY(0%); -ms-transform: translateY(0%); } #block-983835 .tnt-slider-previous { display: inline-block; margin-bottom: 0; font-weight: normal; text-align: center; vertical-align: middle; -ms-touch-action: manipulation; touch-action: manipulation; cursor: pointer; background-image: none; border: 1px solid #ccc; white-space: nowrap; -webkit-user-select: none; -moz-user-select: none; -ms-user-select: none; user-select: none; padding: 5px 10px; font-size: 12px; line-height: 1.5; position: absolute; right: 35px; } #block-983835 .tnt-slider-next { display: inline-block; margin-bottom: 0; font-weight: normal; text-align: center; vertical-align: middle; -ms-touch-action: manipulation; touch-action: manipulation; cursor: pointer; background-image: none; border: 1px solid #ccc; white-space: nowrap; -webkit-user-select: none; -moz-user-select: none; -ms-user-select: none; user-select: none; padding: 5px 10px; font-size: 12px; line-height: 1.5; position: absolute; right: 0px; } #block-983835 .card-panel { height: auto !important; } .follow-links-490080 li { margin-right: 1px; padding: 0; } .follow-links-490080 li a, .follow-links-490080 li a:focus, .follow-links-490080 li a:active { ; color: #fff!important; font-size: 18px; margin-right: 10px; opacity: .8; padding:0; box-shadow: none; } .follow-links-490080 li a:hover { text-decoration: none; opacity: 1; } .follow-links-490080 li a.fb:hover { color: #3A59A5; } .follow-links-490080 li a.tw:hover { color: #46C8F9; } .follow-links-490080 li a.yt:hover { color: #CE2B29; } .follow-links-490080 li a.is:hover { color: #D4C4A2; } #tncms-block-490074 .tnt-prop-img { max-width: 161px; } /*]]>*/</style>
<script type="text/javascript">(function(){var tnsrc=window.location.hash.match(/[&#]tncms-source=([^&]+)/);var dl = window.dataLayer = window.dataLayer || [];dl.push({"townnews":{"product":{"software":"BLOX","version":"1.57.0"}},"tncms":{"template":{"version":"3.155.0"},"page":{"grid":"boxy","style":"default","path":"\/sports","syndicated":"false","reaction":"false","app":"editorial","theme":"flex","skin":"flex-editorial","http_status":200},"subscription":{"required":"false"},"asset":{"author":"Staff Report","id":"c43c7d26-a14f-11eb-8f3c-43e56c881d9a","app":"editorial"},"vendor":{"outbrain":"disabled","taboola":""},"ad":{"vendor":"blox"},"system":{"render_time":205},"client":{"is_bot":"no","is_gdpr":"no"},"google":{"ua":"UA-2821366-10"}}});if (tnsrc && tnsrc[1]) {dl.push({'tncms.campaign.internal_source': tnsrc[1]});}window.addEventListener("DOMContentLoaded", function(oEvent) {var oTest = document.createElement('div');oTest.innerHTML = '&nbsp;';oTest.className = 'adsbox';document.body.appendChild(oTest);var nTimeoutID = window.setTimeout(function() {if (oTest.offsetHeight === 0) {dl.push({'event': 'tncms.ad.blocked'});}document.body.removeChild(oTest);window.clearTimeout(nTimeoutID);}, 100);});var nWidth=Math.max(document.documentElement.clientWidth, window.innerWidth || 0),aBPs=[[300,"Extra small: Most smartphones."],[768,"Small: Tablet devices."],[992,"Medium: Laptops & landscape tablets."],[1200,"Large: Desktop computers."]],i,c,aThisBP,aBP;for(i=0,c=aBPs.length;i<c;i++){aThisBP=aBPs[i];if(aBP===undefined||aThisBP[0]<=nWidth){aBP=aThisBP;}}if(aBP!==undefined){dl.push({'tncms.client.breakpoint':aBP[1]});}(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'tncms.start':new Date().getTime(),event:'tncms.start'});var f=d.getElementsByTagName(s)[0],j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src='https://www.googletagmanager.com/gtm.js?id='+i+dl;f.parentNode.insertBefore(j,f);})(window,document,'script','dataLayer','GTM-PDQV3N');})();</script>
<script src="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/shared-content/art/tncms/templates/libraries/flex/components/jquery/resources/scripts/jquery.min.6edb5af3e93b0a377ec925c5f1c6ddde.js"></script>
<script src="/shared-content/art/tncms/user/user.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/shared-content/art/tncms/templates/libraries/flex/components/bootstrap/resources/scripts/bootstrap.min.d457560d3dfbf1d56a225eb99d7b0702.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/common.5ee3960b4d37bc106988fa535b393865.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.1477faac295a3745e4796d2263e75f11.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/application.93d1db0a57d520951552a1dcd8fd9aeb.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/tnt.navigation.accessibility.3184e9304073379bbe4e2c6500858bb1.js"></script>
<script src="https://polyfill.io/v3/polyfill.min.js?features=default,fetch,IntersectionObserver,NodeList.prototype.@@iterator,Element.prototype.classList|gated" nomodule="nomodule"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.init.c2b9574823d0d16ffc6f20eef83f4232.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/shared-content/art/tncms/templates/libraries/flex/components/ads_blox/resources/scripts/tnt.ads.load.6a3c47703ee96f20ef132e36033ca1bc.js"></script>
<script src="/shared-content/art/tncms/tracking.js"></script>
<script src="/shared-content/art/tncms-ad-manager/admanager.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/ads/impressions.js?_dc=1618895137"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/ads/traffic.js?_dc=1618893335"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/ads/settings.js?_dc=1601405793"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/sms-link.8eefede3265fd6c6de07bc0cb5f3f779.js"></script>
<script async="async" src="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/shared-content/art/tncms/templates/libraries/flex/components/comments/resources/scripts/tnt.facebook.comments.89e3602c68154764e889947868c957c9.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/ads/fixed-big-ad-top/1.js?_dc=1611328404"></script>
<script>/*<![CDATA[*/ window.maillist_signup_config || (window.maillist_signup_config = []); window.maillist_signup_config.push({"heading_tag":"h4","signup_lists_only":"1","heading_bg_color":"","heading_text_color":"inherit","note":"","links_position":"top","bg_color":"","text_color":"inherit","list_ids":"","sign_up_text":"Sign up","manage_button_text":"Manage your lists","show_select_all":"","show_audience":"","hide_audience":"","block_id":"957264"}); /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/ads/fixed-big-ad-middle/1.js?_dc=1618863177"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/ads/fixed-big-ad-bottom/1.js?_dc=1616832068"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/shared-content/art/tncms/templates/libraries/flex/components/ads/resources/scripts/tnt.ads.adverts.66a3812a7b5c12fde8cd998fd691ad7d.js"></script>
<script>/*<![CDATA[*/ __tnt.recentFive = {
    /*
     * Gets the data stored in 'tnt:recent:five'
     * Returns Array
     */
        get:function(){
            if(window.localStorage && localStorage.getItem('tnt:recent:five')!=null){
                try{ return JSON.parse(localStorage.getItem('tnt:recent:five')); } catch {}
            }

            return [];
        },

    /*
     * Sets the 'tnt:recent:five' localStorage item
     * Returns boolean
     */
        set:function(data){
            if(window.localStorage){
                try{ 
                    localStorage.setItem('tnt:recent:five', JSON.stringify(data));
                    return true;
                } catch {}
            }

            return false;
        },

    /*
     * Adds the most recent item, prunes any duplicates, and trims the array down to 5 items
     * Returns Array on success, false on fail 
     */
        add:function(asset){
            var assets = __tnt.recentFive.get();
            assets.unshift(asset);

            if(assets.length > 1){
                assets = assets.filter(function(item, index, a){ return a.indexOf(item) == index });

                while(assets.length>5){
                    assets.shift();
                }
            }

            if(__tnt.recentFive.set(assets)){ return assets; }
            return false;
        }
    }; /*]]>*/</script>

            
            <title>NC State announces Russell Wilson as 2021 commencement speaker | Sports | technicianonline.com</title>
            
    <style>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</style>
    
        <link rel="shortcut icon" type="image/x-icon" href="http://www.technicianonline.com/content/tncms/site/icon.ico" />
    
        <link rel="apple-touch-icon" href="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/custom/image/7b5519e2-5b31-11e6-8770-9f97e834af93.png?resize=180%2C180" />
    
        <link rel="preconnect" href="//www.googletagmanager.com">
    
        <link rel="preconnect" href="//www.google-analytics.com">
    
        <link rel="preconnect" href="//connect.facebook.net">
    <link rel="alternate" type="application/rss+xml" title="NC State announces Russell Wilson as 2021 commencement speaker | Sports | technicianonline.com" href="http://www.technicianonline.com/search/?f=rss&amp;t=article&amp;c=sports&amp;l=50&amp;s=start_time&amp;sd=desc" />
    <link rel="canonical" href="http://www.technicianonline.com/sports/article_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html" />
            <script defer src="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/shared-content/art/tncms/templates/libraries/flex/components/plugins/resources/scripts/fontawesome.edd147e4c2830f416874012247117438.js"></script>
            <script type="text/javascript">
$(function(){
    $(".relocate-block-title .block").each(function(){     
        $(this).find(".block-title").appendTo($(this).find("article"));
    });
});
</script>

        </head>
        <body class="fixed-scroll-nav app-editorial grid-boxy blox-asset uuid-c43c7d26-a14f-11eb-8f3c-43e56c881d9a  section-sports type-article infinity-disabled" data-path="/sports">
	<script type='text/javascript' src='/shared-content/art/stats/common/tracker.js'></script>
	<script type='text/javascript'>
	<!--
	if (typeof(TNStats_Tracker) !== 'undefined' && typeof(TNTracker) === 'undefined') { TNTracker = new TNStats_Tracker('www.technicianonline.com'); TNTracker.trackPageView(); }
	// -->
	</script>
	<noscript><iframe src="https://www.googletagmanager.com/ns.html?id=GTM-PDQV3N&amp;townnews.product.software=BLOX&amp;townnews.product.version=1.57.0&amp;tncms.template.version=3.155.0&amp;tncms.page.grid=boxy&amp;tncms.page.style=default&amp;tncms.page.path=%2Fsports&amp;tncms.page.syndicated=false&amp;tncms.page.reaction=false&amp;tncms.page.app=editorial&amp;tncms.page.theme=flex&amp;tncms.page.skin=flex-editorial&amp;tncms.page.http_status=200&amp;tncms.subscription.required=false&amp;tncms.asset.author=Staff+Report&amp;tncms.asset.id=c43c7d26-a14f-11eb-8f3c-43e56c881d9a&amp;tncms.asset.app=editorial&amp;tncms.vendor.outbrain=disabled&amp;tncms.vendor.taboola=&amp;tncms.ad.vendor=blox&amp;tncms.system.render_time=205&amp;tncms.client.is_bot=no&amp;tncms.client.is_gdpr=no&amp;tncms.google.ua=UA-2821366-10&amp;tncms.client.noscript=yes" height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript><div id="fb-root"></div>
        
        <script type="text/javascript">
TNCMS.AdManager.init
({
  domain: "www.technicianonline.com",
  secureDomain: "technicianonline.com",
  virtualregion: {
            popup: __tnt.ads.popup
        },
  callback: {
            expandable: __tnt.ads.expandable,
            html: __tnt.ads.html,
            image: __tnt.ads.image,
            pagecurl: __tnt.ads.curl,
            text: __tnt.ads.text,
            video: __tnt.ads.video
        }
});
</script>

        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"page-curl","id":"page-curl","pos":"page-curl, atf","fold":"above","size":"[[75,75]]","height":"75","width":"75","not_mobile":true,"refresh":false}' style="display:none;"></div>
        
        <script>
            $(function(){
                var bloxServiceIDs = [];
                var bloxUserServiceIds = [];
                var dataLayer = window.dataLayer || [];

                

                if (__tnt.user.services){
                    var bloxUserServiceIDs = __tnt.user.services.replace('%2C',',').split(',');
                }

                // GTM tncms.subscription.paid_access_service_ids
                if(bloxServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'access_service_ids':bloxServiceIDs.toString()}}});
                }

                // GTM tncms.subscrption.user_service_ids
                if(bloxUserServiceIDs){
                    dataLayer.push({'tncms':{'subscription':{'user_service_ids':bloxUserServiceIDs.toString()}}});
                }
            });
        </script>
        
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-top","id":"fixed-impact-top","pos":"fixed-impact-top, atf","fold":"above","include_domain":null,"size":"[2,1]","height":"1","width":"2","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/technicianonline.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/sports","refresh":false}' style="display:none;"></div>
        <div id="blox-ad-position-_popup1" data-tnt-ads='{"vendor":"blox","type":"position","region":"_popup","id":"_popup","slot":1,"pos":"_popup, atf","size":"[[900,900]]","height":"900","width":"900","display":"popup","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div>
        <div id="site-container"><div id="asset-admin-bar" class="asset-edit-bar hidden-print">
                <div class="asset-edit-icon"><i class="fas tnt-lock-open tnt-fw"></i></div>
                <div class="asset-edit-message">You have permission to edit this article.</div>
                <div class="asset-edit-btns">
                    <a class="btn btn-primary btn-sm" target="_blank" rel="noopener" href="https://www.technicianonline.com/tncms/admin/editorial-asset/?edit=c43c7d26-a14f-11eb-8f3c-43e56c881d9a"><i class="fas tnt-pencil-alt tnt-fw"></i> Edit</a>
                    <button class="asset-edit-close btn btn-link btn-sm"><i class="fas tnt-times"></i><span class="sr-only">Close</span></button>
                </div>
            </div>
        
    
        
        
           <aside class="hidden-print offcanvas-drawer offcanvas-drawer-right visible-sm visible-xs" aria-label="Right Main Menu" aria-expanded="false" tabindex="-1">
                <div id="tncms-region-mobile-nav-top-right-region" class="tncms-region "><div id="tncms-block-490078" class="tncms-block hidden-md hidden-lg"><section id="block-490078" class="block emphasis-h3   " >
    <div class="clearfix"></div>
    <div id="search-form-490078" class="search-form-container card clearfix text-center hidden-print ">
    <form id="site-search-490078" aria-labelledby="site-search-button-490078" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        
        <input type="hidden" name="sort" value="relevance">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group default normal form-control">
        <input id="site-search-490078-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-490078-btn" class="btn btn-link" aria-label="Submit Site Search" type="submit">
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form>
        
        
        <div class="clearfix"></div>
    </div>
    </section> 

<script>
    $('#site-search-490078-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-490078').submit();
        return false;
    });

    $('#site-search-490078').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-490078 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-490078 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-490078-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div></div>
                <div id="tncms-region-nav-mobile-nav-right" class="tncms-region-nav"><div id="mobile-nav-right_menu" class="panel-group nav navbar-nav" role="tablist" aria-hidden="true"><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-1" data-target="#mobile-nav-right_menu-child-1">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/news/"  class="nav-link tnt-section-news">News</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-1" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/coronavirus/"  class="nav-link tnt-section-covid-19-updates">COVID-19 Updates</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-2" data-target="#mobile-nav-right_menu-child-2">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/sports/"  class="nav-link tnt-section-sports">Sports</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-2" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/baseball/"  class="nav-link tnt-section-baseball">Baseball</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/club_sports/"  class="nav-link tnt-section-club-sports">Club Sports</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/cross_country"  class="nav-link tnt-section-cross-country">Cross Country</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/football/"  class="nav-link tnt-section-football">Football</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/golf/"  class="nav-link tnt-section-golf">Golf</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/gymnastics"  class="nav-link tnt-section-gymnastics">Gymnastics</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/hockey/"  class="nav-link tnt-section-hockey">Hockey</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/mens_basketball/"  class="nav-link tnt-section-mens-basketball">Men's Basketball</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/rifle/"  class="nav-link tnt-section-rifle">Rifle</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/soccer/"  class="nav-link tnt-section-soccer">Soccer</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/softball/"  class="nav-link tnt-section-softball">Softball</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/swimming_and_diving/"  class="nav-link tnt-section-swimming-and-diving">Swimming and Diving</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/tennis/"  class="nav-link tnt-section-tennis">Tennis</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/track_and_field/"  class="nav-link tnt-section-track-and-field">Track and Field</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/volleyball/"  class="nav-link tnt-section-volleyball">Volleyball</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/womens_basketball/"  class="nav-link tnt-section-womens-basketball">Women's Basketball</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/sports/wrestling"  class="nav-link tnt-section-wrestling">Wrestling</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-3" data-target="#mobile-nav-right_menu-child-3">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/arts_culture/"  class="nav-link tnt-section-arts-culture">Arts & Culture</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-3" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/arts_culture/bienvenidos/"  class="nav-link tnt-section-bienvenidos">Bienvenidos</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-4" data-target="#mobile-nav-right_menu-child-4">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true" href="/opinion/"  class="nav-link tnt-section-opinion">Opinion</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-4" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/cartoons/"  class="nav-link tnt-section-cartoons">Cartoons</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/columns"  class="nav-link tnt-section-columns">Columns</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/editorials/"  class="nav-link tnt-section-editorials">Editorials</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/opinion/letters_to_editor/"  class="nav-link tnt-section-letters-to-the-editor">Letters to the Editor</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/multimedia/videos/"  class="nav-link tnt-section-video">Video</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" href="/multimedia/"  class="nav-link tnt-section-galleries">Galleries</a>
                        </div>
                    </div></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-7" data-target="#mobile-nav-right_menu-child-7">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true"   class="nav-link tnt-section-advertising">Advertising</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-7" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/advertise/"  class="nav-link tnt-section-advertise-with-us">Advertise With Us</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/classifieds/"  class="nav-link tnt-section-classifieds">Classifieds</a>
                                </li></ul></div><div class="panel panel-default">
                    <div class="panel-heading" role="tab">
                        <div class="panel-title"><a tabindex="-1" aria-hidden="true" data-toggle="collapse" class="expand-children collapsed pull-right" aria-expanded="false" aria-controls="mobile-nav-right_menu-child-8" data-target="#mobile-nav-right_menu-child-8">
                                    <i class="fas tnt-chevron-down"></i>
                                </a><a tabindex="-1" aria-hidden="true"   class="nav-link tnt-section-about">About</a>
                        </div>
                    </div><ul id="mobile-nav-right_menu-child-8" class="collapse nav navbar-nav"><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/about.html"  class="nav-link tnt-section-about-us">About Us</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/editorialstaff.html"  class="nav-link tnt-section-editorial-staff">Editorial Staff</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/work_for_us.html"  class="nav-link tnt-section-work-for-us">Work For Us</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/submissions.html"  class="nav-link tnt-section-submissions">Submissions</a>
                                </li><li>
                                    <a tabindex="-1" aria-hidden="true" href="/site/user_policies.html"  class="nav-link tnt-section-user-policies">User Policies</a>
                                </li></ul></div></div></div>
                
                <div id="tncms-region-mobile-nav-bottom-right-region" class="tncms-region "></div>
            </aside>
        

        <div class="offcanvas-inner">
            <div class="offcanvas-close-btn hidden-md hidden-lg"></div>
    
    
    
    
    <div id="tncms-region-global-skyline" class="tncms-region "></div>
    

    

    

    
    
        <div id="site-navbar-container" class="hidden-print affix-top">
            
            <nav id="main-navigation" class="navbar yamm navbar-default container">
                
                
                <div class="navbar-header">
                    
                    
                    
                        <button  type="button" class="visible-sm visible-xs navbar-toggle pull-right" data-toggle="offcanvas" data-target="right" aria-label="Right Main Menu" aria-expanded="false" >
                            <span class="sr-only">Toggle navigation</span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                            <span class="icon-bar"></span>
                        </button>

                    

                    
                        <div class="navbar-brand pos_right">
                            
                                <div id="tncms-region-main-nav-brand" class="tncms-region "><div id="tncms-block-490073" class="tncms-block"><section id="block-490073" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/custom/image/58d6e5cc-705c-11e6-a234-ff2269afdda9.png?resize=150%2C38 150w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/custom/image/58d6e5cc-705c-11e6-a234-ff2269afdda9.png?resize=200%2C51 200w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/custom/image/58d6e5cc-705c-11e6-a234-ff2269afdda9.png?resize=225%2C57 225w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/custom/image/58d6e5cc-705c-11e6-a234-ff2269afdda9.png?resize=300%2C76 300w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/custom/image/58d6e5cc-705c-11e6-a234-ff2269afdda9.png?resize=400%2C101 400w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/custom/image/58d6e5cc-705c-11e6-a234-ff2269afdda9.png?resize=540%2C137 540w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/custom/image/58d6e5cc-705c-11e6-a234-ff2269afdda9.png?resize=640%2C162 640w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/custom/image/58d6e5cc-705c-11e6-a234-ff2269afdda9.png?resize=750%2C190 750w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/custom/image/58d6e5cc-705c-11e6-a234-ff2269afdda9.png?resize=990%2C251 990w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/custom/image/58d6e5cc-705c-11e6-a234-ff2269afdda9.png 1035w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="1029"
                height="261"
                alt=""></a></div></section></div></div>
                            
                        </div>
                    

                    
                </div>

                
                    <div id="navbar-collapse" class="navbar-collapse collapse">
                        
                            <div class="pull-right">
                                <div id="tncms-region-main-nav-right-region" class="tncms-region "></div>
                                
                            </div>
                        
                        <div class="navbar-left">
                            <div id="tncms-region-nav-main-nav" class="tncms-region-nav"><ul id="main-nav_menu" class="nav navbar-nav" role="navigation" aria-label="Main"><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-news"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/news/"  tabindex="0">
                    <span class="nav-label">News</span>
                </a><ul id="main-nav_menu-child-1" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-covid-19-updates"  href="/coronavirus/"  tabindex="0">
                    <span class="nav-label">COVID-19 Updates</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-sports"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/sports/"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a><ul id="main-nav_menu-child-2" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-baseball"  href="/sports/baseball/"  tabindex="0">
                    <span class="nav-label">Baseball</span>
                </a></li><li>
                <a class="nav-link   tnt-section-club-sports"  href="/sports/club_sports/"  tabindex="0">
                    <span class="nav-label">Club Sports</span>
                </a></li><li>
                <a class="nav-link   tnt-section-cross-country"  href="/sports/cross_country"  tabindex="0">
                    <span class="nav-label">Cross Country</span>
                </a></li><li>
                <a class="nav-link   tnt-section-football"  href="/sports/football/"  tabindex="0">
                    <span class="nav-label">Football</span>
                </a></li><li>
                <a class="nav-link   tnt-section-golf"  href="/sports/golf/"  tabindex="0">
                    <span class="nav-label">Golf</span>
                </a></li><li>
                <a class="nav-link   tnt-section-gymnastics"  href="/sports/gymnastics"  tabindex="0">
                    <span class="nav-label">Gymnastics</span>
                </a></li><li>
                <a class="nav-link   tnt-section-hockey"  href="/sports/hockey/"  tabindex="0">
                    <span class="nav-label">Hockey</span>
                </a></li><li>
                <a class="nav-link   tnt-section-mens-basketball"  href="/sports/mens_basketball/"  tabindex="0">
                    <span class="nav-label">Men's Basketball</span>
                </a></li><li>
                <a class="nav-link   tnt-section-rifle"  href="/sports/rifle/"  tabindex="0">
                    <span class="nav-label">Rifle</span>
                </a></li><li>
                <a class="nav-link   tnt-section-soccer"  href="/sports/soccer/"  tabindex="0">
                    <span class="nav-label">Soccer</span>
                </a></li><li>
                <a class="nav-link   tnt-section-softball"  href="/sports/softball/"  tabindex="0">
                    <span class="nav-label">Softball</span>
                </a></li><li>
                <a class="nav-link   tnt-section-swimming-and-diving"  href="/sports/swimming_and_diving/"  tabindex="0">
                    <span class="nav-label">Swimming and Diving</span>
                </a></li><li>
                <a class="nav-link   tnt-section-tennis"  href="/sports/tennis/"  tabindex="0">
                    <span class="nav-label">Tennis</span>
                </a></li><li>
                <a class="nav-link   tnt-section-track-and-field"  href="/sports/track_and_field/"  tabindex="0">
                    <span class="nav-label">Track and Field</span>
                </a></li><li>
                <a class="nav-link   tnt-section-volleyball"  href="/sports/volleyball/"  tabindex="0">
                    <span class="nav-label">Volleyball</span>
                </a></li><li>
                <a class="nav-link   tnt-section-womens-basketball"  href="/sports/womens_basketball/"  tabindex="0">
                    <span class="nav-label">Women's Basketball</span>
                </a></li><li>
                <a class="nav-link   tnt-section-wrestling"  href="/sports/wrestling"  tabindex="0">
                    <span class="nav-label">Wrestling</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-arts-culture"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/arts_culture/"  tabindex="0">
                    <span class="nav-label">Arts & Culture</span>
                </a><ul id="main-nav_menu-child-3" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-bienvenidos"  href="/arts_culture/bienvenidos/"  tabindex="0">
                    <span class="nav-label">Bienvenidos</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-opinion"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"  href="/opinion/"  tabindex="0">
                    <span class="nav-label">Opinion</span>
                </a><ul id="main-nav_menu-child-4" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-cartoons"  href="/opinion/cartoons/"  tabindex="0">
                    <span class="nav-label">Cartoons</span>
                </a></li><li>
                <a class="nav-link   tnt-section-columns"  href="/opinion/columns"  tabindex="0">
                    <span class="nav-label">Columns</span>
                </a></li><li>
                <a class="nav-link   tnt-section-editorials"  href="/opinion/editorials/"  tabindex="0">
                    <span class="nav-label">Editorials</span>
                </a></li><li>
                <a class="nav-link   tnt-section-letters-to-the-editor"  href="/opinion/letters_to_editor/"  tabindex="0">
                    <span class="nav-label">Letters to the Editor</span>
                </a></li></ul></li><li>
                <a class="nav-link   tnt-section-video"  href="/multimedia/videos/"  tabindex="0">
                    <span class="nav-label">Video</span>
                </a></li><li>
                <a class="nav-link   tnt-section-galleries"  href="/multimedia/"  tabindex="0">
                    <span class="nav-label">Galleries</span>
                </a></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-advertising"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"    tabindex="0">
                    <span class="nav-label">Advertising</span>
                </a><ul id="main-nav_menu-child-7" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-advertise-with-us"  href="/advertise/"  tabindex="0">
                    <span class="nav-label">Advertise With Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-classifieds"  href="/classifieds/"  tabindex="0">
                    <span class="nav-label">Classifieds</span>
                </a></li></ul></li><li class="dropdown" aria-expanded="false">
                <a class="nav-link  dropdown-toggle  tnt-section-about"  data-toggle="dropdown" data-target="#" data-hover="dropdown" data-hover-delay="250"    tabindex="0">
                    <span class="nav-label">About</span>
                </a><ul id="main-nav_menu-child-8" class="dropdown-menu" ><li>
                <a class="nav-link   tnt-section-about-us"  href="/site/about.html"  tabindex="0">
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-editorial-staff"  href="/site/editorialstaff.html"  tabindex="0">
                    <span class="nav-label">Editorial Staff</span>
                </a></li><li>
                <a class="nav-link   tnt-section-work-for-us"  href="/site/work_for_us.html"  tabindex="0">
                    <span class="nav-label">Work For Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submissions"  href="/site/submissions.html"  tabindex="0">
                    <span class="nav-label">Submissions</span>
                </a></li><li>
                <a class="nav-link   tnt-section-user-policies"  href="/site/user_policies.html"  tabindex="0">
                    <span class="nav-label">User Policies</span>
                </a></li></ul></li></ul></div>
                        </div>
                    </div>
                

                
            </nav>
            
            
        </div>
        
            
        
    
    
    <div id="main-body-container">
    <section id="main-top-container" class="container-fullscreen-region container-fluid">
        
        <div class="fullscreen-region"><div id="tncms-region-global-container-top-fullscreen" class="tncms-region "></div></div>
    </section>
    <section id="main-page-container" class="container">
        <div class="row">
                <div id="asset-container-top" class="col-md-12">
                    <div id="tncms-region-asset_container_top" class="tncms-region "></div> 
                </div>
            
            <div class="col-md-12"><div id="tncms-region-global-container-top" class="tncms-region "><div id="tncms-block-489991" class="tncms-block visible-xs">
        <div id="blox-ad-position-block-leaderboard-top-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top-mobile","slot":"1","fold":"above","width":"320","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/technicianonline.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div>
            
                    <div class="row">
                        <div class="col-md-8"><div id="tncms-region-option-custom-top-left" class="tncms-region "><div id="tncms-block-489990" class="tncms-block padding-bottom">
        <div id="blox-ad-position-block-leaderboard-top1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-top","slot":"1","fold":"above","width":"","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/technicianonline.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
                        <div class="col-md-4"><div id="tncms-region-option-custom-top-right" class="tncms-region "><div id="tncms-block-490076" class="tncms-block hidden-xs hidden-sm"><ul id="site-search-490076-dropdown" class="hidden-print nav navbar-nav navbar-right ">
        <li class="search-form-dropdown dropdown">
            <a  onclick="javascript:void(0); return false;"  class="dropdown-toggle" data-hover="dropdown" data-hover-delay="250" data-toggle="dropdown"><span class="fas tnt-search"></span></a>
            <ul class="dropdown-menu">
                <li><form id="site-search-490076" aria-labelledby="site-search-button-490076" action="/search/" method="GET" >
    <input type="hidden" name="l" value="25">
    
        <input type="hidden" name="s" value="start_time">
        <input type="hidden" name="sd" value="desc">
    
    
    
    
    <input type="hidden" name="f" value="html">
    
        
        <input type="hidden" name="t" value="article,video,youtube,collection">
    
    <input type="hidden" name="app" value="editorial">
    <input type="hidden" name="nsa" value="eedition">
    <div class="site-search-form input-group pull-right normal ">
        <input id="site-search-490076-term" name="q" title="Site Search" type="text" placeholder="Search..." class="form-control" autocomplete="off">
        <input type="submit" class="hide" value="Search">
        <span class="input-group-btn">
            <button id="site-search-490076-btn" class="btn btn-primary" aria-label="Submit Site Search" type="submit">
                
	                <span class="hidden-xl hidden-lg hidden-md fas tnt-search"></span>
	                <span id="site-search-button-490076" class="hidden-xs hidden-sm">Search</span>
                
            </button>
        </span>
    </div>
    <div class="clearfix"></div>
</form></ul>
        </li>
    </ul>
 

<script>
    $('#site-search-490076-btn').on(__tnt.client.clickEvent, function(){
        $('#site-search-490076').submit();
        return false;
    });

    $('#site-search-490076').on('submit', function(){
        // Filter query
        var sQueryFiltered = $("#site-search-490076 input[name=q]").val().replace(/\?/g, '');
    $("#site-search-490076 input[name=q]").val( sQueryFiltered );

        if( $('#site-search-490076-term').val() ){
            return true;
        }else{
            return false;
        }
    });</script>
</div><div id="tncms-block-490079" class="tncms-block"><div class="follow-links-490079 pull-right">
    
    <section id="block-490079" class="block emphasis-h3   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/ncsutechnician/" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/ncsutechnician/" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://www.youtube.com/technicianvideo" title="Youtube" target="_blank" rel="noopener" class="btn btn-xs btn-link yt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://www.instagram.com/ncsutechnician" title="Instagram" target="_blank" rel="noopener" class="btn btn-xs btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.technicianonline.com",
  "sameAs" : ["https://www.facebook.com/ncsutechnician/","http://twitter.com/ncsutechnician/","https://www.youtube.com/technicianvideo","https://www.instagram.com/ncsutechnician"]
}
</script>
<div class="clearfix"></div></div></div></div>
                    </div>
            
            </div>
        </div><div id="modal-image-4e67e436-ec62-11e8-a5d6-5fb5b38de91b" class="modal fullscreen in modal-image image-default modal-4e67e436-ec62-11e8-a5d6-5fb5b38de91b" role="dialog" aria-hidden="true" data-lazy-content>
        <template>
            <button type="button" class="close hidden-print" data-dismiss="modal">
                <span aria-hidden="true" class="control-left fas tnt-times-circle"></span>
                <span class="sr-only">Close</span>
            </button>
            <div class="modal-dialog modal-lg">
                <div class="modal-content">
                    <div class="modal-body">
                        <div class="modal-image-container"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                
                
                
        <img
                    src="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/4/e6/4e67e436-ec62-11e8-a5d6-5fb5b38de91b/5bf361181dc71.image.jpg?resize=400%2C266"
                    srcset="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/4/e6/4e67e436-ec62-11e8-a5d6-5fb5b38de91b/5bf361181dc71.image.jpg?resize=150%2C100 150w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/4/e6/4e67e436-ec62-11e8-a5d6-5fb5b38de91b/5bf361181dc71.image.jpg?resize=200%2C133 200w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/4/e6/4e67e436-ec62-11e8-a5d6-5fb5b38de91b/5bf361181dc71.image.jpg?resize=225%2C149 225w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/4/e6/4e67e436-ec62-11e8-a5d6-5fb5b38de91b/5bf361181dc71.image.jpg?resize=300%2C199 300w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/4/e6/4e67e436-ec62-11e8-a5d6-5fb5b38de91b/5bf361181dc71.image.jpg?resize=400%2C266 400w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/4/e6/4e67e436-ec62-11e8-a5d6-5fb5b38de91b/5bf361181dc71.image.jpg?resize=540%2C359 540w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/4/e6/4e67e436-ec62-11e8-a5d6-5fb5b38de91b/5bf361181dc71.image.jpg?resize=640%2C425 640w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/4/e6/4e67e436-ec62-11e8-a5d6-5fb5b38de91b/5bf361181dc71.image.jpg?resize=750%2C498 750w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/4/e6/4e67e436-ec62-11e8-a5d6-5fb5b38de91b/5bf361181dc71.image.jpg?resize=990%2C657 990w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/4/e6/4e67e436-ec62-11e8-a5d6-5fb5b38de91b/5bf361181dc71.image.jpg?resize=1000%2C664 1035w"
                    sizes="100vw"
                    
                    width="1000"
                    height="664"
                    alt="FBvsBC Russell Wilson Runs"
                    class="img-responsive true-size default" />
                
                
            </div>
            
                
                
            
        </figure></div>
                    </div>
                </div>
            </div>
            <div class="modal-caption">
        <div class="caption-container">
                <span class="pull-right photo-carousel-caption-toggle" data-toggle="collapse" data-instance="#carousel-modal-image-4e67e436-ec62-11e8-a5d6-5fb5b38de91b" data-target=".caption-inner-modal-image-4e67e436-ec62-11e8-a5d6-5fb5b38de91b">
                    <i class="fas tnt-minus-circle"></i>
                </span>
            <div class="caption-inner-modal-image-4e67e436-ec62-11e8-a5d6-5fb5b38de91b collapse in"><div class="caption-text"><p>Redshirt junior quarterback Russell Wilson runs the ball against Boston College in Carter-Finley Stadium on Oct. 9, 2010. Wilson had total of 45 rushing yards during the game. NC State won against Boston College 44-17<a href="file:///T:/technician/11.20/Publish/Captions+MES%20+%20BW.docx#_msocom_1"></p><p></a></p></div><div class="card-meta">
                        <ul class="list-inline">
                                    
                                    
                                        <li class="credit"><span  class="tnt-byline">Luis Zapata/Archive</span></li>
                                    
                                
                            
                        </ul>
                    </div>
                    <div class="photo-share">
                        <ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.technicianonline.com%2Fmobile%2Fimage_4e67e436-ec62-11e8-a5d6-5fb5b38de91b.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/mobile/image_4e67e436-ec62-11e8-a5d6-5fb5b38de91b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"4e67e436-ec62-11e8-a5d6-5fb5b38de91b"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=FBvsBC%20Russell%20Wilson%20Runs&via=ncsutechnician&url=http%3A%2F%2Fwww.technicianonline.com%2Fmobile%2Fimage_4e67e436-ec62-11e8-a5d6-5fb5b38de91b.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/mobile/image_4e67e436-ec62-11e8-a5d6-5fb5b38de91b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"4e67e436-ec62-11e8-a5d6-5fb5b38de91b"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=http://www.technicianonline.com/mobile/image_4e67e436-ec62-11e8-a5d6-5fb5b38de91b.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/mobile/image_4e67e436-ec62-11e8-a5d6-5fb5b38de91b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"4e67e436-ec62-11e8-a5d6-5fb5b38de91b"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.technicianonline.com/tncms/asset/editorial/4e67e436-ec62-11e8-a5d6-5fb5b38de91b" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"4e67e436-ec62-11e8-a5d6-5fb5b38de91b"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Btechnicianonline.com%5D%20FBvsBC%20Russell%20Wilson%20Runs&body=http%3A%2F%2Fwww.technicianonline.com%2Fmobile%2Fimage_4e67e436-ec62-11e8-a5d6-5fb5b38de91b.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-image","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"4e67e436-ec62-11e8-a5d6-5fb5b38de91b"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/mobile/image_4e67e436-ec62-11e8-a5d6-5fb5b38de91b.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"4e67e436-ec62-11e8-a5d6-5fb5b38de91b"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-4e67e436-ec62-11e8-a5d6-5fb5b38de91b-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="4e67e436-ec62-11e8-a5d6-5fb5b38de91b" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="4e67e436-ec62-11e8-a5d6-5fb5b38de91b" class="save-list-4e67e436-ec62-11e8-a5d6-5fb5b38de91b-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="4e67e436-ec62-11e8-a5d6-5fb5b38de91b" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="images" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>

                    </div>
            </div>
        </div>
    </div>
            <style>
                #modal-image-4e67e436-ec62-11e8-a5d6-5fb5b38de91b img { max-height: 505px; }
            </style>
        </template>
    </div><article itemscope itemtype="https://schema.org/Article" id="asset-c43c7d26-a14f-11eb-8f3c-43e56c881d9a" class="asset article-default"  data-url="http://www.technicianonline.com/sports/article_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html">
    <span itemscope itemtype="http://schema.org/SpeakableSpecification">
        <meta itemprop="cssSelector" content=".asset-header .headline" />
        <meta itemprop="cssSelector" content=".asset-content p:first-of-type" />
    </span>
    <meta itemprop="description" content="<p>NC State announced on April 19 that former Pack football QB Russell Wilson will speak at this year's commencement ceremonies.</p>"/><div itemprop="publisher" itemscope itemtype="https://schema.org/Organization">
        <div itemprop="logo" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/4/e6/4e67e436-ec62-11e8-a5d6-5fb5b38de91b/5bf361181dc71.image.jpg?resize=949%2C630">
            <meta itemprop="width" content="949">
            <meta itemprop="height" content="630">
        </div>
        <meta itemprop="name" content="technicianonline.com">
    </div>
    <link itemprop="mainEntityOfPage" href="http://www.technicianonline.com/sports/article_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html" />
    <div class="asset-masthead ">
        <header class="asset-header">
    
        <div class="asset-label-flags">
            <span class="tnt-flag label label-flag label-flag-default label-flag-top-story">top story</span> 
        </div>
    
    <h1 itemprop="headline" class="headline">
        <span>
            
            NC State announces Russell Wilson as 2021 commencement speaker
        </span>
    </h1>
    
    <div class="meta">
        <span>
            <ul class="list-inline">
        <li><span itemprop="author" class="tnt-byline">Staff Report</span></li>
        
        
            <li class="visible-print">   
        <time datetime="2021-04-19T16:42:00-04:00" class="asset-date text-muted">8 hrs ago</time></li>
            <li class="hidden-print">   
        <time datetime="2021-04-19T16:42:00-04:00" class="asset-date text-muted">8 hrs ago</time></li>
        
        
            <li class="hidden-print"><a href="/sports/article_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html#comments" class="cm"><span class="fas tnt-comments"></span>
            <span class="sr-only">Comments</span>
        </a></li>
        
        
    </ul>
        </span>
    </div>
    <meta itemprop="dateCreated" content="2021-04-19T16:42:00-04:00">
    <meta itemprop="datePublished" content="2021-04-19T16:42:00-04:00">
    <meta itemprop="dateModified" content="2021-04-19T16:42:00-04:00">
</header>
        
        
            <div class="share-container headline-right pull-right hidden-xs" data-subscription-required-remove><ul class="social-share-links hidden-print list-unstyled stacked icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.technicianonline.com%2Fsports%2Farticle_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/article_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"c43c7d26-a14f-11eb-8f3c-43e56c881d9a"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Share">
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=NC%20State%20announces%20Russell%20Wilson%20as%202021%20commencement%20speaker&via=ncsutechnician&url=http%3A%2F%2Fwww.technicianonline.com%2Fsports%2Farticle_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/article_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"c43c7d26-a14f-11eb-8f3c-43e56c881d9a"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Tweet">
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=http://www.technicianonline.com/sports/article_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/sports/article_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"c43c7d26-a14f-11eb-8f3c-43e56c881d9a"}' >
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="WhatsApp">
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.technicianonline.com/tncms/asset/editorial/c43c7d26-a14f-11eb-8f3c-43e56c881d9a" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"c43c7d26-a14f-11eb-8f3c-43e56c881d9a"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="SMS">
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Btechnicianonline.com%5D%20NC%20State%20announces%20Russell%20Wilson%20as%202021%20commencement%20speaker&body=http%3A%2F%2Fwww.technicianonline.com%2Fsports%2Farticle_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"c43c7d26-a14f-11eb-8f3c-43e56c881d9a"}'  rel="nofollow">
                <span class="tnt-stack" data-toggle="tooltip" data-placement="left" title="Email">
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li></ul></div>
        
    </div>

    

    <div class="row">
        <div class="main-content col-lg-8 col-md-7 has-sidebar"><div class="main-content-wrap">
            <div id="tncms-region-article_top" class="tncms-region hidden-print"></div>
            
            <div class="asset-photo card"><figure class="photo layout-horizontal hover-expand letterbox-style-default"><span class="expand hidden-print"
               
               data-toggle="modal"
                
                    data-target=".modal-4e67e436-ec62-11e8-a5d6-5fb5b38de91b" 
                    >
                       <span class="fas tnt-expand"></span>
                   </span>
            
            <div class="image" 
                 
                    data-toggle="modal" 
                     
                    data-target=".modal-4e67e436-ec62-11e8-a5d6-5fb5b38de91b" 
                    >
                
                
                
                
        <div itemprop="image" itemscope itemtype="https://schema.org/ImageObject">
            <meta itemprop="width" content="1000">
            <meta itemprop="height" content="664">
            <meta itemprop="contentUrl" content="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/4/e6/4e67e436-ec62-11e8-a5d6-5fb5b38de91b/5bf361181dc71.image.jpg">
            <meta itemprop="url" content="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/4/e6/4e67e436-ec62-11e8-a5d6-5fb5b38de91b/5bf361181dc71.image.jpg">
        <img
                    src="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/4/e6/4e67e436-ec62-11e8-a5d6-5fb5b38de91b/5bf361181dc71.image.jpg?resize=400%2C266"
                    srcset="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/4/e6/4e67e436-ec62-11e8-a5d6-5fb5b38de91b/5bf361181dc71.image.jpg?resize=150%2C100 150w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/4/e6/4e67e436-ec62-11e8-a5d6-5fb5b38de91b/5bf361181dc71.image.jpg?resize=200%2C133 200w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/4/e6/4e67e436-ec62-11e8-a5d6-5fb5b38de91b/5bf361181dc71.image.jpg?resize=225%2C149 225w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/4/e6/4e67e436-ec62-11e8-a5d6-5fb5b38de91b/5bf361181dc71.image.jpg?resize=300%2C199 300w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/4/e6/4e67e436-ec62-11e8-a5d6-5fb5b38de91b/5bf361181dc71.image.jpg?resize=400%2C266 400w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/4/e6/4e67e436-ec62-11e8-a5d6-5fb5b38de91b/5bf361181dc71.image.jpg?resize=540%2C359 540w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/4/e6/4e67e436-ec62-11e8-a5d6-5fb5b38de91b/5bf361181dc71.image.jpg?resize=640%2C425 640w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/4/e6/4e67e436-ec62-11e8-a5d6-5fb5b38de91b/5bf361181dc71.image.jpg?resize=750%2C498 750w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/4/e6/4e67e436-ec62-11e8-a5d6-5fb5b38de91b/5bf361181dc71.image.jpg?resize=990%2C657 990w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/4/e6/4e67e436-ec62-11e8-a5d6-5fb5b38de91b/5bf361181dc71.image.jpg?resize=1000%2C664 1035w"
                    sizes="(min-width: 1200px) 750px, (min-width: 992px) calc(66.70vw - 60px), calc(100vw - 30px)"
                    
                    width="1000"
                    height="664"
                    alt="FBvsBC Russell Wilson Runs"
                    class="img-responsive full tnt-restrict-img-4e67e436-ec62-11e8-a5d6-5fb5b38de91b default" />
            </div><style>
                .tnt-restrict-img-4e67e436-ec62-11e8-a5d6-5fb5b38de91b {
                    max-width: 760px;
                }
            </style>
                
                
            </div>
            
                
                
                    <figcaption class="caption">
                            
                                <span class="caption-text">
                                    <p>Redshirt junior quarterback Russell Wilson runs the ball against Boston College in Carter-Finley Stadium on Oct. 9, 2010. Wilson had total of 45 rushing yards during the game. NC State won against Boston College 44-17<a href="file:///T:/technician/11.20/Publish/Captions+MES%20+%20BW.docx#_msocom_1"></p><p></a></p>
                                </span>
                            
                        
                            
                                <span class="credit">
                                    <span  class="tnt-byline">Luis Zapata/Archive</span>
                                </span>
                            
                        
                        <span class="clearfix"></span>
                    </figcaption>
                
            
        </figure></div>

            

            

            <div id="tncms-region-article_top_content" class="tncms-region hidden-print"></div>

            <div id="asset-content" data-asset-uuid="c43c7d26-a14f-11eb-8f3c-43e56c881d9a">
                

                <div class="row">
                    <div class="col-lg-12 col-md-12 col-sm-12" data-subscription-required-class="col-xs-12">
                        
                        <div class="asset-body" data-subscription-required-class="asset-body">
                            
                                <div class="share-container content-above" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.technicianonline.com%2Fsports%2Farticle_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/article_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"c43c7d26-a14f-11eb-8f3c-43e56c881d9a"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=NC%20State%20announces%20Russell%20Wilson%20as%202021%20commencement%20speaker&via=ncsutechnician&url=http%3A%2F%2Fwww.technicianonline.com%2Fsports%2Farticle_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/article_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"c43c7d26-a14f-11eb-8f3c-43e56c881d9a"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=http://www.technicianonline.com/sports/article_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/sports/article_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"c43c7d26-a14f-11eb-8f3c-43e56c881d9a"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.technicianonline.com/tncms/asset/editorial/c43c7d26-a14f-11eb-8f3c-43e56c881d9a" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"c43c7d26-a14f-11eb-8f3c-43e56c881d9a"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Btechnicianonline.com%5D%20NC%20State%20announces%20Russell%20Wilson%20as%202021%20commencement%20speaker&body=http%3A%2F%2Fwww.technicianonline.com%2Fsports%2Farticle_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"c43c7d26-a14f-11eb-8f3c-43e56c881d9a"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/sports/article_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"c43c7d26-a14f-11eb-8f3c-43e56c881d9a"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-c43c7d26-a14f-11eb-8f3c-43e56c881d9a-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="c43c7d26-a14f-11eb-8f3c-43e56c881d9a" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="c43c7d26-a14f-11eb-8f3c-43e56c881d9a" class="save-list-c43c7d26-a14f-11eb-8f3c-43e56c881d9a-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="c43c7d26-a14f-11eb-8f3c-43e56c881d9a" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            

                            <div id="tncms-region-article_body_top" class="tncms-region hidden-print"></div>

                            <div  itemprop="articleBody" class="asset-content  subscriber-premium">
                                <meta itemprop="isAccessibleForFree" content="true"/>
                                
                                
                                <p dir="ltr">Former NC State football quarterback and current Seattle Seahawk Russell Wilson is set to be the 2021 commencement speaker, the University announced Monday, April 19. Wilson will speak at both the May 14 and May 15 ceremonies.</p><p dir="ltr">“We are honored to welcome Russell Wilson back to NC State to inspire our spring 2021 graduates at these very special commencement ceremonies,” said <a href="https://news.ncsu.edu/2021/04/russell-wilson-to-address-spring-2021-grads/">Chancellor Randy Woodson in the announcement</a>. “Russell has always supported his alma mater well and represented NC State with class. We know our students, their families and our entire Wolfpack community will be excited to see Russell back home at Carter-Finley Stadium.”</p><p dir="ltr">Wilson is one of Pack football’s all-time greats, ranking fourth in career passing yards (8,545), second in passing touchdowns (76), sixth in completion percentage (.578), third in 300-yard games (12), second in rushing by a quarterback (1,083 yards) and fourth in total offense (9,628 yards).</p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top-asset","id":"fixed-big-ad-top-asset","pos":"fixed-big-ad-top-asset, atf","fold":"above","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/technicianonline.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/sports","refresh":false}' style="display:none;"></div><div id="tncms-region-article_instory_top" class="tncms-region hidden-print"></div><p dir="ltr">In the NFL, Wilson won Super Bowl XLVIII and has been selected to the Pro Bowl eight times. Since he joined the NFL, Wilson has started every game for the Seahawks and consistently posted stellar numbers year after year.</p><p dir="ltr">Off the field, Wilson has been recognized for his great volunteer work, including his nonprofit (the Why Not You Foundation), being awarded the Walter Payton Man of the Year award in 2020.</p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-middle-asset","id":"fixed-big-ad-middle-asset","pos":"fixed-big-ad-middle-asset, stf","fold":"span","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/technicianonline.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/sports","refresh":false}' style="display:none;"></div><div id="tncms-region-article_instory_middle" class="tncms-region hidden-print"></div><p dir="ltr">Wilson previously spoke at last year’s virtual graduation ceremony for student-athletes.</p><blockquote class="twitter-tweet"><p lang="en" dir="ltr">Some incredible words from <a href="https://twitter.com/DangeRussWilson?ref_src=twsrc%5Etfw">@DangeRussWilson</a> at today’s graduation ceremony for our student-athletes. A huge thanks to him for being a part of this special day! Whole speech coming soon, but for now, hear Russell talk about his love for NC State: <a href="https://t.co/68tT7IK7tj">pic.twitter.com/68tT7IK7tj</a></p>&mdash; NC State Athletics (@PackAthletics) <a href="https://twitter.com/PackAthletics/status/1258876553162747904?ref_src=twsrc%5Etfw">May 8, 2020</a></blockquote><p dir="ltr">In addition to speaking at the ceremonies, Wilson will confer honorary degrees to alumni Jeff Williams, chief operating officer at Apple, and Ashley Christensen, James Beard Award-winning chef.</p><p dir="ltr">Both ceremonies will be livestreamed, according to the release, and Wilson will be joined in speaking by university leaders and graduating students.</p>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom-asset","id":"fixed-big-ad-bottom-asset","pos":"fixed-big-ad-bottom-asset, btf","fold":"below","include_domain":null,"size":"[300,250]","height":"250","width":"300","mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/technicianonline.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/sports","refresh":false}' style="display:none;"></div><div id="tncms-region-article_instory_bottom" class="tncms-region hidden-print"></div>
                                <div id="tncms-region-article_bottom_content" class="tncms-region hidden-print"></div>
                                
                            </div>

                            

                            
    


                            
                                <div class="share-container content-below" data-subscription-required-remove><ul class="social-share-links hidden-print list-inline icon"><li class="social-share-link fb">
        <a href="https://www.facebook.com/sharer/sharer.php?u=http%3A%2F%2Fwww.technicianonline.com%2Fsports%2Farticle_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html%3Futm_medium%3Dsocial%26utm_source%3Dfacebook%26utm_campaign%3Duser-share" class="tnt-share-link fb" target="_blank" rel="noopener nofollow" title="Share on Facebook"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Facebook","socialAction":"post","url":"/sports/article_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"c43c7d26-a14f-11eb-8f3c-43e56c881d9a"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-facebook-f tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Facebook</span>
            </a>
        </li><li class="social-share-link tw">
            <a href="https://twitter.com/intent/tweet?&text=NC%20State%20announces%20Russell%20Wilson%20as%202021%20commencement%20speaker&via=ncsutechnician&url=http%3A%2F%2Fwww.technicianonline.com%2Fsports%2Farticle_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html%3Futm_medium%3Dsocial%26utm_source%3Dtwitter%26utm_campaign%3Duser-share" class="tnt-share-link tw" target="_blank" rel="noopener nofollow" title="Tweet"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"Twitter","socialAction":"tweet","url":"/sports/article_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"c43c7d26-a14f-11eb-8f3c-43e56c881d9a"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-twitter tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Twitter</span>
            </a>
        </li><li class="social-share-link wa">
            <a href="https://wa.me/?text=http://www.technicianonline.com/sports/article_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html" class="tnt-share-link wa" target="_blank" rel="noopener nofollow" title="WhatsApp"  data-toggle="new-window" data-new-window-width="500" data-new-window-height="300" data-track='{"network":"WhatsApp","socialAction":"share","url":"/sports/article_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"c43c7d26-a14f-11eb-8f3c-43e56c881d9a"}' >
                <span class="tnt-stack" >
                    
                    <i class="fab tnt-whatsapp tnt-stack-1x"></i>
                </span>
                <span class="sr-only">WhatsApp</span>
            </a>
        </li><li class="social-share-link sms" style="display:none;">
            <a href="sms:?body=Check%20out%20this%20link:%20www.technicianonline.com/tncms/asset/editorial/c43c7d26-a14f-11eb-8f3c-43e56c881d9a" class="tnt-share-link sms" title="SMS" data-track='{"category":"tnt-sms","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"sms","uuid":"c43c7d26-a14f-11eb-8f3c-43e56c881d9a"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-comment-alt-dots tnt-stack-1x"></i>
                </span>
                <span class="sr-only">SMS</span>
            </a>
        </li><li class="social-share-link em">
            <a href="mailto:?subject=%5Btechnicianonline.com%5D%20NC%20State%20announces%20Russell%20Wilson%20as%202021%20commencement%20speaker&body=http%3A%2F%2Fwww.technicianonline.com%2Fsports%2Farticle_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html%3Futm_medium%3Dsocial%26utm_source%3Demail%26utm_campaign%3Duser-share" class="tnt-share-link em email-share-link" title="Email"  data-track='{"category":"tnt-email","action":"share","label":"editorial-article","value":""}' data-tncms-track-event='{"app":"editorial","metric":"email","uuid":"c43c7d26-a14f-11eb-8f3c-43e56c881d9a"}'  rel="nofollow">
                <span class="tnt-stack" >
                    
                    <i class="fas tnt-envelope tnt-stack-1x"></i>
                </span>
                <span class="sr-only">Email</span>
            </a>
        </li><li class="social-share-link pr">
                <a href="javascript:window.print()" class="pr" title="Print" data-track='{"network":"Print","socialAction":"print","url":"/sports/article_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html"}' data-tncms-track-event='{"app":"editorial","metric":"social_share","uuid":"c43c7d26-a14f-11eb-8f3c-43e56c881d9a"}'  rel="nofollow">
                    <span class="tnt-stack" >
                        
                        <i class="fas tnt-print tnt-stack-1x"></i>
                    </span>
                    <span class="sr-only">Print</span>
                </a>
            </li><li class="social-share-link sv">
        <a class="save-list-c43c7d26-a14f-11eb-8f3c-43e56c881d9a-btn save-asset " title="Save to list" href="#"  role="button" rel="nofollow" data-asset-uuid="c43c7d26-a14f-11eb-8f3c-43e56c881d9a" >
            
                <span class="tnt-stack">
                    
                    <i class="asset-save-icon far tnt-bookmark tnt-stack-1x "></i>
                </span>
            
            
                <span class="sr-only">Save</span>
            
        </a>
        </li>
        
    </ul><form method="post" data-uuid="c43c7d26-a14f-11eb-8f3c-43e56c881d9a" class="save-list-c43c7d26-a14f-11eb-8f3c-43e56c881d9a-form save-asset-to-list" action="/users/admin/list/">
        <input type="hidden" name="action" value="addasset" />
        <input type="hidden" name="format" value="json" />
        <input type="hidden" name="listasset" value="c43c7d26-a14f-11eb-8f3c-43e56c881d9a" />
        <input type="hidden" name="listapp" value="editorial" />
        <input type="hidden" name="autocreate" value="true" />
        <input type="hidden" name="listname" value="articles" />
        <input class="hide" type="submit" name="submit" value="Save" />
    </form>
</div>
                            
                        </div>
                        
                    </div></div><!-- /asset-content -->

                <div id="asset-below">
                    

                    

                    

                    

                    

                    
                        <div class="asset-tags hidden-print">
                            <h4>Tags</h4>
                            <ul class="list-inline"><li>
                <a href="/search/?k=%22ncsu%20football%22#tncms-source=keyword" class="tag-ncsu-football label label-default" >Ncsu Football</a>
            </li> <li>
                <a href="/search/?k=%22wolfpack%20football%22#tncms-source=keyword" class="tag-wolfpack-football label label-default" >Wolfpack Football</a>
            </li> <li>
                <a href="/search/?k=%22gopack%20football%22#tncms-source=keyword" class="tag-gopack-football label label-default" >Gopack Football</a>
            </li> <li>
                <a href="/search/?k=%22nc%20state%20football%22#tncms-source=keyword" class="tag-nc-state-football label label-default" >Nc State Football</a>
            </li> <li>
                <a href="/search/?k=%22russell%20wilson%22#tncms-source=keyword" class="tag-russell-wilson label label-default" >Russell Wilson</a>
            </li> <li>
                <a href="/search/?k=%22the%20nfl%22#tncms-source=keyword" class="tag-the-nfl label label-default" >The Nfl</a>
            </li> <li>
                <a href="/search/?k=%22carter-finley%20stadium%22#tncms-source=keyword" class="tag-carter-finley-stadium label label-default" >Carter-finley Stadium</a>
            </li> <li>
                <a href="/search/?k=%22super%20bowl%22#tncms-source=keyword" class="tag-super-bowl label label-default" >Super Bowl</a>
            </li> <li>
                <a href="/search/?k=%22commencement%20speaker%22#tncms-source=keyword" class="tag-commencement-speaker label label-default" >Commencement Speaker</a>
            </li> <li>
                <a href="/search/?k=%22national%20football%20league%22#tncms-source=keyword" class="tag-national-football-league label label-default" >National Football League</a>
            </li> <li>
                <a href="/search/?k=%22quarterback%22#tncms-source=keyword" class="tag-quarterback label label-default" >Quarterback</a>
            </li> <li>
                <a href="/search/?k=%22jeff%20williams%22#tncms-source=keyword" class="tag-jeff-williams label label-default" >Jeff Williams</a>
            </li> <li>
                <a href="/search/?k=%22nfl%22#tncms-source=keyword" class="tag-nfl label label-default" >Nfl</a>
            </li> <li>
                <a href="/search/?k=%22randy%20woodson%22#tncms-source=keyword" class="tag-randy-woodson label label-default" >Randy Woodson</a>
            </li> <li>
                <a href="/search/?k=%22ashley%20christensen%22#tncms-source=keyword" class="tag-ashley-christensen label label-default" >Ashley Christensen</a>
            </li> <li>
                <a href="/search/?k=%22walter%20payton%20man%22#tncms-source=keyword" class="tag-walter-payton-man label label-default" >Walter Payton Man</a>
            </li> <li>
                <a href="/search/?k=%22the%20pro%20bowl%22#tncms-source=keyword" class="tag-the-pro-bowl label label-default" >The Pro Bowl</a>
            </li> <li>
                <a href="/search/?k=%22chancellor%22#tncms-source=keyword" class="tag-chancellor label label-default" >Chancellor</a>
            </li> </ul>
                        </div>
                    

                    

                    

                    

                    

                    

                    

                    

                    <div id="tncms-region-article_bottom" class="tncms-region hidden-print"></div>

                    <div class="asset-comments hidden-print">
                
                <div id="comments-container" class="comments-container">
                    
                    <div
                        id="comments" 
                        class="fb-comments" 
                        data-href="http://www.technicianonline.com/tncms/asset/editorial/c43c7d26-a14f-11eb-8f3c-43e56c881d9a/" 
                        data-num-posts="10" 
                        data-width="100%" 
                    ></div>
                    <style>
                        .fb_iframe_widget,
                        .fb_iframe_widget span,
                        .fb_iframe_widget span iframe[style]{
                            min-width:100%!important;
                            width:100%!important;
                        }
                    </style>
                </div>
            
        </div>
                    
                    <div id="tncms-region-article_container_bottom" class="tncms-region hidden-print"></div></div>
            </div>

            

            </div>
        </div><div class="main-sidebar col-lg-4 col-md-5 hidden-print">
                <div class="main-sidebar-wrap">
                    <div id="tncms-region-article_side_top" class="tncms-region hidden-print"></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-top","id":"fixed-big-ad-top","pos":"fixed-big-ad-top, atf","fold":"above","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/technicianonline.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/sports","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-top" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-top1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-top', slot: 1, fold: "above"});</script>

</div>
</div>
<div id="tncms-region-asset_side_top" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-primary" class="tncms-region "><div id="tncms-block-957264" class="tncms-block"><section id="block-957264" class="block emphasis-h4   " ><div class=""><div class="card email-signup">
        <div class="alert alert-success" role="alert" style="display:none;">
            <p>
                <strong>Success!</strong> An email has been sent to <strong><span class="user-email"></span></strong> with a link to confirm list signup.
            </p>
        </div>
        <div class="alert alert-danger" role="alert" style="display:none;">
            <p>
                <strong>Error!</strong> There was an error processing your request.
            </p>
        </div>
        <div class="mailinglist-container">
                <form
                    id="mailinglist-form-957264"
                    class="mailinglist-form form-validate"
                    action="/tncms/mailinglist/signup/"
                    method="post">
                    <input type="hidden" name="submit" value="1">
                    <div class="form-group mailing-lists ">
                        
                            <div class="mailinglist-item priority-0 ">
                                
                                    <input class="mailinglist-id-957264" type="checkbox" name="list_id[]" value="2eb9a060-d118-11ea-ae08-83afc017a616" data-name="Weekly Newsletter" title="Weekly Newsletter" style="display:none;" checked>
                                    <h4 class="mailinglist-title">Weekly Newsletter</h4>
                                    
                                        <p><span data-sheets-value="{&quot;1&quot;:2,&quot;2&quot;:&quot;Best trending stories from the week.&quot;}" data-sheets-userformat="{&quot;2&quot;:513,&quot;3&quot;:{&quot;1&quot;:0},&quot;12&quot;:0}">Top Technician stories delivered to your inbox each Thursday</span></p>
                                    
                                
                            </div>
                        
                    </div>

                    

                    <div class="form-group  email-address">
                        <div class="input-group">
                            <span class="input-group-addon"><i class="fas tnt-envelope"></i></span>
                            <input id="email-957264" class="form-control email" title="email" name="email" type="email" placeholder="Enter email address">
                        </div>
                        <label class="warning-email hide has-error text-danger" for="email">Please enter a valid email address.</label>
                    </div>
                    <div class="row">
                        <div class="mailinglist-btn-container col-sm-6">
                            <button class="mailinglist-save btn btn-primary btn-block">Sign up<i class="fas tnt-spinner tnt-spin" style="display:none; margin-left:5px;"></i></button>
                        </div>
                        <div class="mailinglist-btn-container col-sm-6">
                            <a class="btn btn-default btn-block" href="https://www.technicianonline.com/users/admin/mailinglist/">Manage your lists</a>
                        </div>
                    </div>
                </form>
            </div>
        
    </div></div></section></div><div id="tncms-block-507920" class="tncms-block"><a id="techDigitalPrint" target="_blank" style="margin:0 auto;margin-bottom: 40px; width:300px;height:380px;display:block;background-image: none; background-size: 100%; background-repeat: no-repeat;" href="https://studentmedia.ncsu.edu/technician-digital-edition/redirect.php">
    		<div style="position: absolute;display: block;background-color: rgba(0,0,0,.3);width:300px;height:380px;">
            </div>
   			<div style="position: absolute;display: table;text-align: center;width:300px;height:380px;">
                <div style="display: table-cell;table-layout:fixed;vertical-align: middle;color: #FFF;">
                    <div style="border-width:2px;width:50%;margin-left:25%;">
                        <span style="font-size: 2.4em;">PRINT</span><br><span style="font-size: 1.5em;display: block; margin-top: -10px;">EDITION</span>
                    </div>
                </div>            
         </div>
     </a></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-middle","id":"fixed-big-ad-middle","pos":"fixed-big-ad-middle, stf","fold":"span","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/technicianonline.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/sports","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-middle" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-middle1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-middle', slot: 1, fold: "span"});</script>

</div>
</div>
<div id="tncms-region-asset_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-article_side_middle" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-secondary" class="tncms-region hidden-print"><div id="tncms-block-901401" class="tncms-block"><div class="block-media-player">
        <section id="block-901401" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-901401 ">
        <div class="block-title-inner">
            <h3>
                
                    <a href="http://www.technicianonline.com/multimedia/videos/">
                
                Latest Sports Video
                
                    </a>
                
            </h3>
        </div>
    </div></div>
        <div class="card-grid card-img-">
            <div class="row">
                        <div class="card col-sm-12">
                            <article id="card-showcase-9d9ce560-126c-11eb-b3bb-978763f644d7" class="clearfix card showcase position-0 odd  tnt-section-multimedia tnt-sub-section-videos">
            <div class="card-container"><div class="card-image ">
                <div class="media-preview-9d9ce560-126c-11eb-b3bb-978763f644d7 media-preview video-asset" data-aspect="16:9">
        <div class="youtube-video-container video-responsive hidden-print">
            <iframe id="youtube-player-9d9ce560-126c-11eb-b3bb-978763f644d7" class="youtube" style="min-height:250px" src="//www.youtube.com/embed/HDlQF7XXduk?enablejsapi=1&origin=https://www.technicianonline.com" allowfullscreen></iframe>
            <script>__tnt.youtube.players.register('youtube-player-9d9ce560-126c-11eb-b3bb-978763f644d7');</script>
        </div>
    
    <script type="application/ld+json">
            {
                "@context": "https://schema.org",
                "@type": "VideoObject",
                "name": "NCSU Volleyball Falls to UNC-Chapel Hill",
                "description": "NCSU women's volleyball falls to UNC-Chapel Hill again 1-3. Video by: Emily Elliott Website: http://www.technicianonline.com/ Twitter: https://twitter.com/NCSUTechnician Facebook: https://www.facebook.com/ncsutechnician/ Instagram: https://www.instagram.com/ncsutechnician/",
                "thumbnailUrl": "https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/9/d9/9d9ce560-126c-11eb-b3bb-978763f644d7/5f8e3200b77c3.preview.jpg?resize=1200%2C675",
                "uploadDate": "2020-10-19T20:38:00-04:00"
            }
        </script><script type="application/ld+json">
            {
                "@context": "https://schema.org",
                "@type": "VideoObject",
                "name": "NCSU Volleyball Falls to UNC-Chapel Hill",
                "description": "NCSU women's volleyball falls to UNC-Chapel Hill again 1-3. Video by: Emily Elliott Website: http://www.technicianonline.com/ Twitter: https://twitter.com/NCSUTechnician Facebook: https://www.facebook.com/ncsutechnician/ Instagram: https://www.instagram.com/ncsutechnician/",
                "thumbnailUrl": "https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/9/d9/9d9ce560-126c-11eb-b3bb-978763f644d7/5f8e3200b77c3.preview.jpg?resize=1200%2C675",
                "uploadDate": "2020-10-19T20:38:00-04:00"
            }
        </script></div>
            </div><div class="card-body">
        <div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/multimedia/videos/video_9d9ce560-126c-11eb-b3bb-978763f644d7.html" class="tnt-asset-link">
        

        
            NCSU Volleyball Falls to UNC-Chapel Hill</a></h3></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-byline text-muted"><span id="author-8a4a8e56-d5c1-11e9-a5a6-fb78667ce3e3-asset-9d9ce560-126c-11eb-b3bb-978763f644d7" class="tnt-byline asset-byline"  >Emily Elliott, Staff Videographer</span>
                </li><li class="card-date">   
        <time datetime="2020-10-19T20:38:00-04:00" class="asset-date text-muted">Oct 19, 2020</time></li></ul>
        </div>
                    </div>
            </div>
            <div class="clearfix"></div>
        </article></div>
                    </div>

                    <div class="clearfix hidden-xs"></div>
            </div>
        </section></div></div><div id="tncms-block-983835" class="tncms-block"><section id="block-983835" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-983835 ">
        <div class="block-title-inner">
            <h3>
                
                Latest Sports Gallery
                
            </h3>
        </div>
    </div></div><div class="card-grid   card-img-md">
        
        
            <div class=" ">
        
        <div class="  last-grid-item">
                 
                                
                    <article id="card-summary-983835-08d56b72-a06b-11eb-a50e-4b83be8ad403" class="tnt-asset-type-collection clearfix card summary has-image image-top inherit letterbox-style-default  tnt-section-gallery">
            <div class="card-container"><div class="card-image card-image-top">
                        <div class="media-preview-08d56b72-a06b-11eb-a50e-4b83be8ad403 media-preview collection-asset" data-aspect="original"><figure class="photo layout-horizontal letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/gallery/collection_08d56b72-a06b-11eb-a50e-4b83be8ad403.html" class="tnt-asset-link" >                
                
                    <div class="asset-icon"><i class="fas tnt-camera tnt-fw" title="Image gallery"></i> +26</div>
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="Softball vs. LSU - Game 2"
                            class="img-responsive lazyload full default"
                            width="1637"
                            height="1265"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/0/8d/08d56b72-a06b-11eb-a50e-4b83be8ad403/607c6cbe6ecb2.preview.jpg?resize=150%2C116 150w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/0/8d/08d56b72-a06b-11eb-a50e-4b83be8ad403/607c6cbe6ecb2.preview.jpg?resize=200%2C155 200w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/0/8d/08d56b72-a06b-11eb-a50e-4b83be8ad403/607c6cbe6ecb2.preview.jpg?resize=225%2C174 225w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/0/8d/08d56b72-a06b-11eb-a50e-4b83be8ad403/607c6cbe6ecb2.preview.jpg?resize=300%2C232 300w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/0/8d/08d56b72-a06b-11eb-a50e-4b83be8ad403/607c6cbe6ecb2.preview.jpg?resize=400%2C309 400w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/0/8d/08d56b72-a06b-11eb-a50e-4b83be8ad403/607c6cbe6ecb2.preview.jpg?resize=540%2C417 540w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/0/8d/08d56b72-a06b-11eb-a50e-4b83be8ad403/607c6cbe6ecb2.preview.jpg?resize=640%2C495 640w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/0/8d/08d56b72-a06b-11eb-a50e-4b83be8ad403/607c6cbe6ecb2.preview.jpg?resize=750%2C580 750w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/0/8d/08d56b72-a06b-11eb-a50e-4b83be8ad403/607c6cbe6ecb2.preview.jpg?resize=990%2C765 990w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/0/8d/08d56b72-a06b-11eb-a50e-4b83be8ad403/607c6cbe6ecb2.preview.jpg?resize=1035%2C800 1035w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/0/8d/08d56b72-a06b-11eb-a50e-4b83be8ad403/607c6cbe6ecb2.preview.jpg?resize=1200%2C927 1200w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/0/8d/08d56b72-a06b-11eb-a50e-4b83be8ad403/607c6cbe6ecb2.preview.jpg?resize=1333%2C1030 1333w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/0/8d/08d56b72-a06b-11eb-a50e-4b83be8ad403/607c6cbe6ecb2.preview.jpg?resize=1476%2C1141 1476w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/0/8d/08d56b72-a06b-11eb-a50e-4b83be8ad403/607c6cbe6ecb2.preview.jpg?resize=1637%2C1265 2008w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body">
        <div class="card-headline"><h3 class="tnt-headline ">
        
             <a href="/gallery/collection_08d56b72-a06b-11eb-a50e-4b83be8ad403.html" class="tnt-asset-link">
        

        
            Softball vs. LSU - Game 2</a></h3></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-byline text-muted"><span  class="tnt-byline">Sarah Cochran, Senior Staff Photographer</span></li><li class="card-date">
        <time datetime="2021-04-18T13:25:00-04:00" class="asset-date text-muted">Apr 18, 2021</time>
    </li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
                </div>
                
            
            
            
            
        
        
        
        
        </div>
        </div></section></div><div id="tncms-block-954181" class="tncms-block custom-add-seperator"><section id="block-954181" class="block emphasis-h3   " ><div class="clearfix">
    
    <div class="block-title title-954181 ">
        <div class="block-title-inner">
            <h3>
                
                First and Tech Podcast
                
            </h3>
        </div>
    </div></div>
    
    <div class="card-img-md card-compact">
        
                
                <article id="card-summary-954181-aaf419e0-24aa-11eb-b2bf-eb584d338521" class="tnt-asset-type-audio clearfix card summary has-image image-left inherit letterbox-style-default  tnt-section-multimedia tnt-sub-section-podcasts">
            <div class="card-container"><div class="card-image ">
                        <div class="media-preview-aaf419e0-24aa-11eb-b2bf-eb584d338521 media-preview audio-asset" data-aspect="original"><figure class="photo layout-square letterbox-style-default">
            <div class="image" 
                >
                
                    <a href="/multimedia/podcasts/audio_aaf419e0-24aa-11eb-b2bf-eb584d338521.html" class="tnt-asset-link" >                
                
                    <div class="asset-icon"><i class="fas tnt-headphones tnt-fw" title="Audio"></i> 31:32</div>
                
                
                
        
                        <img
                            src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg=="
                            alt="First and Tech Vol. 101, Ep. 2: Pack football overperforming, 8-3 a legit possibility?"
                            class="img-responsive lazyload full default"
                            width="400"
                            height="400"
                            data-sizes="auto"
                            data-srcset="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/0/d1/0d183f36-3d9b-11ea-9d11-df46b6fe4f16/5e2924c186488.image.jpg?resize=150%2C150 150w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/0/d1/0d183f36-3d9b-11ea-9d11-df46b6fe4f16/5e2924c186488.image.jpg?resize=200%2C200 200w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/0/d1/0d183f36-3d9b-11ea-9d11-df46b6fe4f16/5e2924c186488.image.jpg?resize=225%2C225 225w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/0/d1/0d183f36-3d9b-11ea-9d11-df46b6fe4f16/5e2924c186488.image.jpg?resize=300%2C300 300w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/assets/v3/editorial/0/d1/0d183f36-3d9b-11ea-9d11-df46b6fe4f16/5e2924c186488.image.jpg?resize=400%2C400 400w" />
                </a>
                
            </div>
            
        </figure></div>
                    </div>
                
                <div class="card-body">
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/multimedia/podcasts/audio_aaf419e0-24aa-11eb-b2bf-eb584d338521.html" class="tnt-asset-link">
        

        
            First and Tech Vol. 101, Ep. 2: Pack football overperforming, 8-3 a legit possibility?</a></h4></div>
    <div class="card-meta">
            <ul class="list-inline"><li class="card-byline text-muted"><span  class="tnt-byline">Camden Speight, Sports Editor and Jaylan Harrington, Multimedia Managing Editor</span></li><li class="card-date">   
        <time datetime="2020-11-12T00:00:00-05:00" class="asset-date text-muted">Nov 12, 2020</time></li></ul>
        </div>
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div>
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-big-ad-bottom","id":"fixed-big-ad-bottom","pos":"fixed-big-ad-bottom, btf","fold":"below","include_domain":null,"size":"[[300,250], [300,600]]","height":"250","width":"300","not_mobile":false,"js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/technicianonline.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":null,"index_slug":null,"url":"\/sports","refresh":false}' style="display:none;"></div><div id="tncms-region-ads-fixed-big-ad-bottom" class="tncms-region-ads">

<div id="blox-ad-position-fixed-big-ad-bottom1">
<script type="text/javascript">TNCMS.AdManager.render({region: 'fixed-big-ad-bottom', slot: 1, fold: "below"});</script>

</div>
</div>
<div id="tncms-region-asset_side_bottom" class="tncms-region hidden-print"></div><div id="tncms-region-global-side-tertiary" class="tncms-region "><div id="tncms-block-955772" class="tncms-block custom-add-seperator"><section id="block-955772" class="block emphasis-h3    tnt-no-margin-bottom" ><div class="clearfix">
    
    <div class="block-title title-955772 ">
        <div class="block-title-inner">
            <h3>
                
                The Latest
                
            </h3>
        </div>
    </div></div>
    
    <div class="card-img-md card-compact">
        
                
                <article id="card-summary-955772-461df0fe-a17d-11eb-9322-6742d4f60133" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-opinion">
            <div class="card-container">
                
                <div class="card-body"><div class="card-labels">
            
                
                <div class="card-label-section text-muted">
                    <a href="/opinion" class="tnt-section-tag">Opinion</a>
                </div>
            
            </div>
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/opinion/article_461df0fe-a17d-11eb-9322-6742d4f60133.html" class="tnt-asset-link">
        

        
            OPINION: Seniors, don’t beat yourself up over senioritis, because you’re not alone</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-955772-1da9d8ac-a17a-11eb-ac99-1b09b50bd1f1" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-sports">
            <div class="card-container">
                
                <div class="card-body"><div class="card-labels">
            
                
                <div class="card-label-section text-muted">
                    <a href="/sports" class="tnt-section-tag">Sports</a>
                </div>
            
            </div>
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/sports/article_1da9d8ac-a17a-11eb-ac99-1b09b50bd1f1.html" class="tnt-asset-link">
        

        
            COMMENTARY: Vaccinations for athletes should be mandatory now</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-955772-52ccae70-a179-11eb-b294-f714535d55c5" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-sports">
            <div class="card-container">
                
                <div class="card-body"><div class="card-labels">
            
                
                <div class="card-label-section text-muted">
                    <a href="/sports" class="tnt-section-tag">Sports</a>
                </div>
            
            </div>
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/sports/article_52ccae70-a179-11eb-b294-f714535d55c5.html" class="tnt-asset-link">
        

        
            Inconsistent offense, young pitching highlight recent NC State baseball performances</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-955772-c43c7d26-a14f-11eb-8f3c-43e56c881d9a" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-sports">
            <div class="card-container">
                
                <div class="card-body"><div class="card-labels">
            
                
                <div class="card-label-section text-muted">
                    <a href="/sports" class="tnt-section-tag">Sports</a>
                </div>
            
            </div>
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/sports/article_c43c7d26-a14f-11eb-8f3c-43e56c881d9a.html" class="tnt-asset-link">
        

        
            NC State announces Russell Wilson as 2021 commencement speaker</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            
                
                <article id="card-summary-955772-fe7ca17a-a0a3-11eb-939d-a37f5f341c78" class="tnt-asset-type-article clearfix card summary inherit letterbox-style-default  tnt-section-opinion">
            <div class="card-container">
                
                <div class="card-body"><div class="card-labels">
            
                
                <div class="card-label-section text-muted">
                    <a href="/opinion" class="tnt-section-tag">Opinion</a>
                </div>
            
            </div>
        <div class="card-headline"><h4 class="tnt-headline ">
        
             <a href="/opinion/article_fe7ca17a-a0a3-11eb-939d-a37f5f341c78.html" class="tnt-asset-link">
        

        
            OPINION: Lara Trump as a North Carolina senator? No thanks!</a></h4></div>
    
                    
                    
                    
                    
                    
                    
                    
                    
                </div>
            </div>
            <div class="clearfix"></div>
        </article>
                
            </div></section></div></div><div id="tncms-region-article_side_bottom" class="tncms-region hidden-print"></div>
                <div id="sticky-right-rail-spacer">
                    <div id="sticky-right-rail"><div id="tncms-region-global-side-sticky" class="tncms-region hidden-print"></div><div id="tncms-region-asset_side_sticky" class="tncms-region hidden-print"></div></div>
                </div>
                </div>
            </div></div>
</article>
<div class="row">
            <div class="col-md-12"><div id="tncms-region-global-container-bottom" class="tncms-region "><div id="tncms-block-489992" class="tncms-block">
        <div id="blox-ad-position-block-leaderboard-bottom1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom","slot":"1","fold":"below","width":"","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/technicianonline.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div><div id="tncms-block-489993" class="tncms-block visible-xs">
        <div id="blox-ad-position-block-leaderboard-bottom-mobile1" data-tnt-ads='{"vendor":"blox","type":"position","display":"default","region":"block-leaderboard-bottom-mobile","slot":"1","fold":"below","width":"320","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/technicianonline.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"overline":"","refresh":false}' class="blox-ad tnt-ads-container ">
        
        </div></div></div></div>
        </div></section>
    <section id="main-bottom-container" class="container-fullscreen-region container-fluid">
        <div class="fullscreen-region"><div id="tncms-region-global-container-bottom-fullscreen" class="tncms-region "></div></div>
    </section><!-- / main-body-container -->
    </div>
    <div id="site-footer-container" class="hidden-print">
         
            <div class="container">
                <div id="asset-container-bottom" class="col-md-12">
                    <div id="tncms-region-asset_container_bottom" class="tncms-region hidden-print"></div> 
                </div>
            </div>
        

        
            <footer id="site-footer" class="container well-main">
                
                <div id="tncms-region-footer-top-col-full" class="tncms-region "></div>
                <div class="row">
                    <div id="footer-col-one" class="col-md-3 col-sm-3">
        <div id="tncms-region-footer-col-logo" class="tncms-region "><div id="tncms-block-490080" class="tncms-block footer-social-icons"><div class="follow-links-490080 default">
    
    <section id="block-490080" class="block emphasis-h4   " ><ul class="list-inline">
        
            <li>
                <a href="https://www.facebook.com/ncsutechnician/" title="Facebook" target="_blank" rel="noopener" class="btn btn-xs btn-link fb" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-facebook-f"></i>
                    <span class="sr-only">Facebook</span>
                </a>
            </li>
        
        
            <li>
                <a href="http://twitter.com/ncsutechnician/" title="Twitter" target="_blank" rel="noopener" class="btn btn-xs btn-link tw" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-twitter"></i>
                    <span class="sr-only">Twitter</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://www.youtube.com/channel/UCjut_3WJ0I-92_ZxCMM5etw" title="Youtube" target="_blank" rel="noopener" class="btn btn-xs btn-link yt" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-youtube"></i>
                    <span class="sr-only">YouTube</span>
                </a>
            </li>
        
        
        
            <li>
                <a href="https://www.instagram.com/ncsutechnician" title="Instagram" target="_blank" rel="noopener" class="btn btn-xs btn-link is" data-toggle="tooltip" data-placement="bottom">
                    <i class="fab tnt-instagram"></i>
                    <span class="sr-only">Instagram</span>
                </a>
            </li>
        
        
        
        
        
        
        
        
        
        
        
        
    </ul>
    </section>
</div>
<script type="application/ld+json">
{ "@context" : "https://schema.org",
  "@type" : "Organization",
  "url" : "http://www.technicianonline.com",
  "sameAs" : ["https://www.facebook.com/ncsutechnician/","http://twitter.com/ncsutechnician/","https://www.youtube.com/channel/UCjut_3WJ0I-92_ZxCMM5etw","https://www.instagram.com/ncsutechnician"]
}
</script>
<div class="clearfix"></div></div><div id="tncms-block-490074" class="tncms-block padding-bottom footer-logo"><section id="block-490074" class="block emphasis-h3   " ><div class="block"><a href="/" rel="nofollow" >
            <img 
                
                src="data:image/png;base64,iVBORw0KGgoAAAANSUhEUgAAAAQAAAADCAQAAAAe/WZNAAAAEElEQVR42mM8U88ABowYDABAxQPltt5zqAAAAABJRU5ErkJggg==" 
                data-srcset="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/custom/image/59f0fff8-791a-11e6-9cd1-a7345ef169cb.png?resize=150%2C361 150w, https://bloximages.newyork1.vip.townnews.com/technicianonline.com/content/tncms/custom/image/59f0fff8-791a-11e6-9cd1-a7345ef169cb.png 200w" 
                data-sizes="auto" 
                class=" img-responsive lazyload tnt-prop-img"
                width="161"
                height="387"
                alt=""></a></div></section></div></div>
    </div>
    <div id="footer-col-two" class="col-md-2 col-sm-2">
        <div id="tncms-region-footer-col-one" class="tncms-region "><div id="tncms-block-490067" class="tncms-block"><section id="block-490067" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-490067 ">
        <div class="block-title-inner">
            <h4>
                
                Sections
                
            </h4>
        </div>
    </div></div></section></div></div>
        <div id="tncms-region-nav-footer-col-one-nav" class="tncms-region-nav"><ul id="footer-col-one-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link   tnt-section-home"  href="http://www.technicianonline.com"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Home</span>
                </a></li><li>
                <a class="nav-link   tnt-section-news"  href="/news/"  tabindex="0">
                    <span class="nav-label">News</span>
                </a></li><li>
                <a class="nav-link   tnt-section-sports"  href="/sports/"  tabindex="0">
                    <span class="nav-label">Sports</span>
                </a></li><li>
                <a class="nav-link   tnt-section-arts-culture"  href="/arts_culture/"  tabindex="0">
                    <span class="nav-label">Arts & Culture</span>
                </a></li><li>
                <a class="nav-link   tnt-section-opinion"  href="/opinion/"  tabindex="0">
                    <span class="nav-label">Opinion</span>
                </a></li><li>
                <a class="nav-link   tnt-section-photo"  href="/multimedia/"  tabindex="0">
                    <span class="nav-label">Photo</span>
                </a></li><li>
                <a class="nav-link   tnt-section-video"  href="/multimedia/videos/"  tabindex="0">
                    <span class="nav-label">Video</span>
                </a></li></ul></div>
    </div>
    <div id="footer-col-three" class="col-md-2 col-sm-2">
        <div id="tncms-region-footer-col-two" class="tncms-region "><div id="tncms-block-490068" class="tncms-block"><section id="block-490068" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-490068 ">
        <div class="block-title-inner">
            <h4>
                
                Services
                
            </h4>
        </div>
    </div></div></section></div></div>
        <div id="tncms-region-nav-footer-col-two-nav" class="tncms-region-nav"><ul id="footer-col-two-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link   tnt-section-about-us"  href="/site/about.html"  tabindex="0">
                    <span class="nav-label">About Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-contact-us"  href="/site/contact.html"  tabindex="0">
                    <span class="nav-label">Contact Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-work-for-us"  href="/site/work_for_us.html"  tabindex="0">
                    <span class="nav-label">Work For Us</span>
                </a></li><li>
                <a class="nav-link   tnt-section-submissions"  href="/site/submissions.html"  tabindex="0">
                    <span class="nav-label">Submissions</span>
                </a></li><li>
                <a class="nav-link   tnt-section-user-policies"  href="/site/user_policies.html"  tabindex="0">
                    <span class="nav-label">User Policies</span>
                </a></li><li>
                <a class="nav-link   tnt-section-advertise"  href="/advertise/"  tabindex="0">
                    <span class="nav-label">Advertise</span>
                </a></li></ul></div>
    </div>
    <div id="footer-col-four" class="col-md-2 col-sm-2">
        <div id="tncms-region-footer-col-three" class="tncms-region "><div id="tncms-block-500816" class="tncms-block"><section id="block-500816" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-500816 ">
        <div class="block-title-inner">
            <h4>
                
                Affiliates
                
            </h4>
        </div>
    </div></div></section></div></div>
        <div id="tncms-region-nav-footer-col-three-nav" class="tncms-region-nav"><ul id="footer-col-three-nav_menu" class="bullet-nav nav-list" ><li>
                <a class="nav-link   tnt-section-agromeck"  href="https://studentmedia.ncsu.edu/agromeck"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Agromeck</span>
                </a></li><li>
                <a class="nav-link   tnt-section-nubian-message"  href="https://www.thenubianmessage.com/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Nubian Message</span>
                </a></li><li>
                <a class="nav-link   tnt-section-windhover"  href="https://windhover.ncsu.edu/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">Windhover</span>
                </a></li><li>
                <a class="nav-link   tnt-section-wknc"  href="https://wknc.org/"  target="_blank" rel="noopener" tabindex="0">
                    <span class="nav-label">WKNC</span>
                </a></li><li>
                <a class="nav-link   tnt-section-roundabout"  href="/roundabout/"  tabindex="0">
                    <span class="nav-label">Roundabout</span>
                </a></li></ul></div>
    </div>
    <div id="footer-col-five" class="col-md-3 col-sm-3">
        <div id="tncms-region-footer-col-contact" class="tncms-region "><div id="tncms-block-490070" class="tncms-block"><section id="block-490070" class="block emphasis-h4   " ><div class="clearfix">
    
    <div class="block-title title-490070 ">
        <div class="block-title-inner">
            <h4>
                
                Contact Information
                
            </h4>
        </div>
    </div></div><address>
    <strong>technicianonline.com</strong><br>
    323 Witherspoon Student Center, Campus Box 7318<br>
    Raleigh, NC 27695
    <br>
    
        <strong>Phone:</strong> 919-515-2411<br>
        <strong>Email:</strong> <a href="mailto:technician-editor@ncsu.edu">technician-editor@ncsu.edu</a><br>
    
</address></section></div></div>
    </div>
                </div>
                <div id="tncms-region-footer-bottom-col-full" class="tncms-region "><div id="tncms-block-827545" class="tncms-block"><script type="text/javascript">
     $(document).ready(function(){
     setTimeout(function(){ 
         $("#techDigitalPrint").css("background-image", "url(https://studentmedia.ncsu.edu/technician-digital-edition/today.php");
         $("#techDigitalNewsLetter").css("background-image", "url(https://studentmedia.ncsu.edu/technician-digital-edition/today.php");
         
     }, 300);
});


	
</script></div></div>
                
            </footer>
        

        <div id="site-copyright-container" class="container">
            <div id="tncms-region-footer-copyright" class="tncms-region "><div id="tncms-block-490071" class="tncms-block"><div id="site-copyright" class="row">
    <section id="block-490071"><div class="col-md-7"><small>&copy; Copyright 2021 <a href="/">technicianonline.com</a>, 323 Witherspoon Student Center, Campus Box 7318 Raleigh, NC</small><small>&nbsp;| <a href="/site/about.html">Terms of Use</a></small></div>
        <div class="col-md-5"><small>Powered by <a href="https://bloxcms.com" title="BLOX Content Management System" target="_blank" rel="noopener">BLOX Content Management System</a> from <a href="https://townnews.com/" title="TownNews.com BLOX Newspaper Content Management" target="_blank" rel="noopener">TownNews.com</a>.</small></div>
    </section>
</div></div></div>
        </div>
    </div>
    
    
        </div><!-- / offcanvas close  -->
    

    
    
    <!-- / site-container close -->
    </div>
    
    
        <div data-tnt-ads-tmp='{"vendor":"blox","type":"region","region":"fixed-impact-bottom","id":"fixed-impact-bottom","pos":"fixed-impact-bottom, btf","fold":"below","include_domain":null,"size":"[1,1]","height":"1","width":"1","js":{"video":"https:\/\/bloximages.newyork1.vip.townnews.com\/technicianonline.com\/shared-content\/art\/tncms\/templates\/libraries\/flex\/components\/video\/resources\/scripts\/video.512a6903eae08e033c76afdce2a0eac7.js"},"index_slug":null,"url":"\/sports","refresh":false}' style="display:none;"></div>
    <script>
        window.__tnt = window.__tnt || {};
        __tnt.compatibility = __tnt.compatibility || {};

        __tnt.compatibility.status = '';
        __tnt.compatibility.check = function() {
            if (typeof __tnt.advertisements == 'undefined') {
                __tnt.compatibility.status = 'FAIL: object 0 undefined';
                return false;
            }
            return true;
        };
        __tnt.compatibility.notification = function() {
            if (!document.getElementById('notification-area')) {
                    var el = document.createElement('div');
                    el.id = 'notification-area';
                    document.querySelector('#asset-content .asset-body').appendChild(el);
                }
                __tnt.template(
                    document.getElementById('template-blox-message-incompatible'),
                    document.getElementById('notification-area'),
                    true,
                    [],
                    function(el) {
                        setTimeout(function() {
                            var message = document.getElementById('blox-message-incompatible');
                            var authStatusCls = (__tnt.user.authToken) ? 'logged-in' : 'not-logged-in';
                                Array.from(message.getElementsByClassName(authStatusCls)).forEach(function(el) {
                                    el.style.display = 'block';
                                });
                            
                            if (__tnt.user.services) {
                                message.parentNode.removeChild(message);
                            } else {
                                message.style.display = 'block';
                                }
                        }, 100);
                    }
                );
            };
        (function() {
            function compatibilityCheck() {
                if (!__tnt.compatibility.check()) {
                    __tnt.trackEvent({
                        'category':'subscription',
                        'action':'adblock',
                        'label':'adblock detected',
                        'value':'1'
                    });
                    __tnt.compatibility.notification();
                }
            }

            if (document.readyState != 'loading') {
                compatibilityCheck();
            } else {
                document.addEventListener('DOMContentLoaded', compatibilityCheck);
            }
        })();
    </script>
    <template id="template-blox-message-incompatible">
            </template>
    
    
    <script>
        jQuery(function() {
            if(typeof TNCMS.Tracking != 'undefined'){
                jQuery(TNCMS.Tracking.trackDeclarativeEvents);
            }dataLayer.push({'tncms.client.recent_five':__tnt.recentFive.add("c43c7d26-a14f-11eb-8f3c-43e56c881d9a")});});
    </script>

    <script>
        __tnt.trackEvent = function(obj) {
            if (typeof obj === 'object') {
                    if (obj.category && obj.action) {
                        __tnt.googleEvent(obj);
                    } else if (obj.network && obj.socialAction) {
                        __tnt.googleSocial(obj);
                    } else if (obj.url) {
                        __tnt.googlePageView(obj);
                    }
                    if (typeof TNCMS.Tracking != 'undefined' && obj.metric) {
                        TNCMS.Tracking.addEvent({
                            app: obj.app,
                            metric: obj.metric,
                            id: obj.uuid
                        });
                    }
            }
        };

        if (__tnt.trackEventLater.length > 0) {
            __tnt.trackEventLater.forEach(function(obj) {
                __tnt.trackEvent(obj);
            });
        }

        Array.from(document.querySelectorAll('body [data-track]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.track));
            });
        });
        Array.from(document.querySelectorAll('body [data-tncms-track-event]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                __tnt.trackEvent(JSON.parse(el.dataset.tncmsTrackEvent));
            });
        });
        
        Array.from(document.querySelectorAll('body [data-tncms-track-dmp]')).forEach(function(el) {
            el.addEventListener(__tnt.client.clickEvent, function() {
                var dmpData = el.dataset.tncmsTrackDmp;
                
            });
        });
    
    </script>
    
    <!-- Place tag before closing body tag on all site pages -->
<script type="text/javascript">!function(){var e=document.createElement("script");e.type="text/javascript",e.async=!0,e.src="//www.rtb123.com/tags/773F3C17-7C67-20A7-40A0-F1BBB5264072/btp.js";var t=document.getElementsByTagName("head")[0];t?t.appendChild(e,t):(t=document.getElementsByTagName("script")[0]).parentNode.insertBefore(e,t)}();</script>
<script>/*<![CDATA[*/ 
                __tnt.googleEvent = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.trigger',
                             'tncms.event.trigger.category': obj.category,
                             'tncms.event.trigger.action': obj.action,
                             'tncms.event.trigger.label': obj.label, 
                             'tncms.event.trigger.value': obj.value
                    });
                }
                /* Virtual page view */
                __tnt.googlePageView = function(obj) {
                    var sURL = obj.url.replace(/^.*\/\/[^\/]+/, '');
                    dataLayer.push({
                        'event': 'tncms.event.virtual_pageview',
                            'tncms.event.virtual_pageview.url': sURL,
                            'tncms.event.virtual_pageview.title': obj.title
                    });
                }
                /* Social event */
                __tnt.googleSocial = function(obj) {
                    dataLayer.push({
                        'event': 'tncms.event.social',
                            'tncms.event.social.network': obj.network,
                            'tncms.event.social.action': obj.socialAction,
                            'tncms.event.social.target': obj.url
                    });
                } /*]]>*/</script>
<script src="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/shared-content/art/tncms/templates/libraries/flex/components/template/resources/scripts/asset-edit.60e8e67e04be1194326dcfbe7f00b8c3.js"></script>
<script>/*<![CDATA[*/ 
                        !function(t,i,n){var e,a,s,o,c,d={init:function(){a=i.getElementById("site-navbar-container"),n.client.platform.ios?a.classList.add("affix-sticky"):(e=i.getElementById("main-body-container"),s=a.offsetHeight||a.clientHeight,o=!1,c=0,t.addEventListener("scroll",d.navPosition,!1),t.addEventListener("mousewheel",d.navPosition,!1))},navPosition:function(){o||(o=!0,setTimeout(function(){var n=a.getBoundingClientRect(),d=t.pageYOffset||i.documentElement.scrollTop,f=n.top+d;d>=f&&d>c?a.classList.contains("affix")||(c=f,a.classList.add("affix"),a.classList.remove("affix-top"),e.style.marginTop=s+"px"):a.classList.contains("affix-top")||(a.classList.remove("affix"),a.classList.add("affix-top"),e.style.marginTop="0px"),o=!1},25))}};"loading"==i.readyState?i.addEventListener("DOMContentLoaded",d.init,!1):d.init()}(window,document,__tnt);
                    document.addEventListener('DOMContentLoaded', function() {
                        var isIOS = /iPad|iPhone|iPod/.test(navigator.userAgent) && !window.MSStream;
                        if (isIOS) {
                            Array.from(document.querySelectorAll('[data-toggle="offcanvas"]')).forEach(function(drawer) {
                                drawer.addEventListener("mouseover", function(e) {
                                    var drawerCls = drawer.dataset.target === 'left' ? 'active-left' : 'active-right';
                                    document.documentElement.classList.add('drawer-open', drawerCls);
                                })
                            })
                        }
                    }); /*]]>*/</script>
<script>/*<![CDATA[*/ 
            // Observer callback
            var callback = function(entries, io) {
                entries.forEach(function(e) {
                    if (e.isIntersecting === true) {
                        __tnt.template(
                            document.querySelector('#' + e.target.id + ' template'),
                            document.getElementById(e.target.id),
                            false,
                            objectFitImages('#' + e.target.id + ' img') // IE11 objectfit polyfill
                        );
                        // Kill observer
                        io.unobserve(e.target);
                    }
                });
            };
            // Initialize observer
            window.addEventListener('load', function() {
                var io = new IntersectionObserver(callback),
                    targets = Array.from(document.querySelectorAll('[data-lazy-content]')); // IE11 forEach support
                targets.forEach(function(e){
                    io.observe(e);
                });
            }, false) /*]]>*/</script>
<script src="//platform.twitter.com/widgets.js"></script>
<script src="https://bloximages.newyork1.vip.townnews.com/technicianonline.com/shared-content/art/tncms/templates/libraries/flex/components/block/resources/scripts/maillist_signup.deacc71a82fe583ccc361b42498ff614.js"></script></body>
</html>